User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: 2.2 Direct misfire codes- help please!

  1. #1
    New Member
    Join Date
    Feb 2009
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused 2.2 Direct misfire codes- help please!

    Hi there. Bought my lovely Signum 2.2 direct last week. 04 reg with 27k on the clock and in pretty tidy condition. Problem is a mis-fire at high revs and over 70mph. I've changed the plugs, air filter and the coil bar thingy but its no better. The OBDII error codes are always only listed as cylinder mis-fire and its a different one each time. What do you suggest next changing please? Any help much appreciated and if anyone in Surrey wants to pop over to clear error codes or run the diagnostics then drop me a line! Cheers.

  2. #2
    Regular Member BigP's Avatar
    Join Date
    Apr 2006
    Location
    Heated, Electric Recaro Leather
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi mate, don't know the answer but just to let you know your not alone, there are a few people on here at the moment (including me) with the same problem. Hope you get it sorted ASAP.

  3. #3
    Regular Member
    Join Date
    Jan 2008
    Location
    ipswich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what error codes is it saying as i have a tech2 reader with code book

  4. #4
    Regular Member markd3925's Avatar
    Join Date
    Oct 2008
    Location
    Eindhoven
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra GTS


    Engine : 3.2 V6

    Year : 2003

    Default

    fuel pump or regulator common problem

  5. #5
    Regular Member steve1975l's Avatar
    Join Date
    Mar 2008
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the fuel pump to me.

  6. #6
    New Member
    Join Date
    Feb 2009
    Location
    Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Update

    Having replaced the coil bar thing, plugs and air filter (which had more moths and butterflies in it than London Zoo) I identified an error through my OBDII reader which didn't come up as an error code (only the misfires had) but showed that the position 1 Lamdba probe had failed. Its a five wire Titanium coated one apparently so only main dealer could supply. Ordered it, being delivered tomorrow so will update when fitted! Thanks for the replies.

  7. #7
    Regular Member markd3925's Avatar
    Join Date
    Oct 2008
    Location
    Eindhoven
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra GTS


    Engine : 3.2 V6

    Year : 2003

    Default

    the sensor will read incorrect because the misfire is causing the wrong fuel/air ratio

    its the effect not the cause of you problem

    it will be a fuel pressure issue regulator or pump, more like pump like steve said as it misfires not cutting out like the regulator tends to cause

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 direct misfire
    By lh_4827 in forum Engine & Drivetrain
    Replies: 52
    Last Post: 22nd November 2013, 19:55
  2. Feels like a misfire but no fault codes!
    By signum_1.9 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 9th December 2012, 02:03
  3. 2.2 Direct 54 misfire sometimes
    By rodzynx in forum Engine & Drivetrain
    Replies: 9
    Last Post: 4th March 2012, 12:22
  4. misfire on gas help with fault codes
    By zub in forum Engine & Drivetrain
    Replies: 2
    Last Post: 23rd September 2010, 17:15
  5. misfire and crankshaft error codes
    By shadow.warrior in forum Engine & Drivetrain
    Replies: 6
    Last Post: 26th July 2010, 00:54

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •