User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: any advice would help.

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default any advice would help.

    my Vectra 2.2 Direct Sri (05reg) has developed a 'juddery' acceleration problem recently, it appears after 5 minutes or so of driving , the motor starts to judder, when idling there's a 'choking, splutter' sound.

    a mate recently dismantled and cleaned the 'swirl' assembly, as the a fault code of 'Swirl Actuactor Stuck' came up. After the cleaning, we thought it had cured the problem, but a week or so later the problem seems a lot worse. Is it better to replace with new one completely? how much to buy and where to buy?

    any advice?

  2. #2
    Regular Member Sean-2.2Direct's Avatar
    Join Date
    Apr 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hmm mate its possible that the High Pressure fuel pump is going but it might not be in this case.
    Whats it like when driving is it fine through all the revs?? is it just juddering when Idleing??

    If its just doing it when idleing clean the Throttle body as it tends to collect alot of nasty stuff around there If that has no effect Im not sure if the EGR valve could have somthing to do with this someone else will be along thats had this problem before Hang tight mate
    Last edited by Sean-2.2Direct; 23rd February 2009 at 13:02.

  3. #3
    Regular Member
    Join Date
    Jan 2009
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Sean-2.2Direct View Post
    Hmm mate its possible that the High Pressure fuel pump is going but it might not be in this case.
    Whats it like when driving is it fine through all the revs?? is it just juddering when Idleing??

    If its just doing it when idleing clean the Throttle body as it tends to collect alot of nasty stuff around there If that has no effect Im not sure if the EGR valve could have somthing to do with this someone else will be along thats had this problem before Hang tight mate
    OMG..the dreaded High Pressure Fuel Pump!!! ..

    The car drives fine throughout the rev range (even upto the redline) but after say 5-10 minutes driving the ****** thing starts acting as if its going into cardiac arrest, the car is still driveable, but not smooth.

    any more ideas?

  4. #4
    Regular Member
    Join Date
    Feb 2009
    Location
    newcastle upon tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    have u checked the spark plugs

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    With it red lining I'd say it ether the fuel regulator or Manifold/Swirl actuator system. Modern cars mate i'm afraid, its such a tiresome bit of advice but its best hooked up to Tech 2. I doubt its the plugs, if anything it could be the coil pack, but as said, there are so many things it could be.

  6. #6
    Regular Member BigP's Avatar
    Join Date
    Apr 2006
    Location
    Heated, Electric Recaro Leather
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Don't know the answer mate but my 05 plate Direct with 35k on the clock started doing exactly the same this week!
    Put the EML on for a few days although that seems to have cleared now.
    If I had to guess I would look at Coil pack, EGR valve and maybe MAF sensor as I'm pretty sure when the fuel pump problem arises it completely losses power.
    Let me know if you fix it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ebay advice , think someone is trying it on , need advice ...
    By poves in forum General Motoring Chat
    Replies: 7
    Last Post: 22nd August 2012, 00:29
  2. Need help and advice please
    By Angel1368 in forum Engine & Drivetrain
    Replies: 32
    Last Post: 9th June 2012, 11:19
  3. Need advice what would you do....
    By pipamish in forum General Motoring Chat
    Replies: 11
    Last Post: 2nd December 2011, 02:13
  4. Newbe after advice, lots of advice!
    By rb199 in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 10th March 2011, 19:08
  5. Advice please?
    By RN37 VXL in forum Engine & Drivetrain
    Replies: 10
    Last Post: 16th October 2009, 17:59

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •