User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: abs light

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    greenock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default abs light

    after some heavy breaking the abs light in my car is now on and the abs isnt working

    could this be a sign that the pads or disks need changing?

    or is it something more major?

    57 cdti?

  2. #2
    Regular Member BlueRob's Avatar
    Join Date
    Jul 2006
    Location
    Mexico
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    To my knowledge only the hand brake light turns on when pads needs changing.
    A proper code reading might be needed.
    HTH

  3. #3
    Regular Member Robclowes's Avatar
    Join Date
    Oct 2007
    Location
    Crewe/Market Drayton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I also had this happen and needed a new hub!!!

  4. #4
    Regular Member VECTRAMAN's Avatar
    Join Date
    Apr 2007
    Location
    Bridgend/South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 1.9 CDTI Design Estate

    Trim : Half leather

    Engine : 1900

    Year : 2006

    Mileage : 116k

    Default

    Most likely the abs sensors are unable to read correct wheel speed. Happened to me after wheel spin trying to get out of street in Snow. Just turn off and then drive the car and sensors should re-teach and read wheel speed-mine did took about 5-10 miles.

  5. #5
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Could be the speed sensor wiring connector has got water in it. Fairly common problem for the front left wheel. Have a look behind the hub and you will see the sensor wire clipped into the suspension leg. Disconnect the wiring plug and see if there is water in it, dry and refit may solve the problem. Worth doing on both fronts.

  6. #6
    Regular Member DKM's Avatar
    Join Date
    May 2008
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep, ste hit the nail on the head, mine had water in the connection and caused abs light to show.
    I squirted some WD-40 in there, no problem since.

  7. #7
    Regular Member
    Join Date
    Aug 2008
    Location
    greenock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    went in the car today and its fixed itself lol!

    maybe the water drained out? but its deffo working now

  8. #8
    Regular Member dan mann's Avatar
    Join Date
    Jun 2006
    Location
    Never in one location for long
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    These things can happen.

  9. #9
    Regular Member BlueRob's Avatar
    Join Date
    Jul 2006
    Location
    Mexico
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The more gadgets a car has the more glitches.
    Glad its sorted.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 4
    Last Post: 18th August 2012, 08:58
  3. Replies: 17
    Last Post: 16th August 2012, 10:07
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Fitted rear light,illuminated sunvisors and map reading light
    By glenboy in forum Vectra C / Signum Car Chat
    Replies: 26
    Last Post: 30th March 2008, 10:51

Visitors found this page by searching for:

2006 vectra c abs light on

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •