User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Help needed for Sick Signum CDTI with problems

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help needed for Sick Signum CDTI with problems

    My Signum broke down the other night and I now THE CAR STARTS, BUT DOESN'T REV and I also have 3 fault codes:

    Code: P1491 Fan control (wiring, engine blower motor, ecm or relay).
    Code: P380 Glow Plug circuit (wiring, glowplug fuse or ecm)
    Code: P1901 Exhaust Gas Pressure sensor (wiring, sensor or ecm)

    I did find the 20amp fuse under the bonnet blown (now replaced and the car now starts but won't rev up), the glow plugs were all working; however, I have still replaced them and I have voltage to the all glow plugs.

    The idling common rail (CR) fuel pressure is 38.80 mpa, voltage 1.31v, fuel pressure control value 31% and fuel metering soleniod reads 1.39%.

    At 1500rpm the CR fuel pressure is 95.82 mpa, voltage 2.64v, fuel pressure control value 31% and fuel metering soleniod reads 1.39%.

    Could this all be a red-herring and maybe actually be an EGR fault?

  2. #2
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What engine is you CDTI

  3. #3
    Regular Member Danwells72's Avatar
    Join Date
    Jul 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9 cdti 150

    Year : 2004

    Default

    Sounds like a loom but i dont know much about the common rail

  4. #4
    Regular Member
    Join Date
    Jan 2009
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Signum 1.9 CDTI Problems

    Quote Originally Posted by sb1uk View Post
    What engine is you CDTI
    Yes it's a 1.9 CDTI (DT19 engine). I spoke to Skurrays today and the Workshop manager did say that, given that my car has done 67,000 miles (motorway) with no history of an EGR change it could well be the EGR that's causing the problems.

    I have taken a day off (holiday) tomorrow to strip down the EGR valve in line with the excellent procedure described in the Vectra C/Signum forum. Time will tell!

  5. #5
    Regular Member
    Join Date
    Aug 2008
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    EGR cleaning a well worth exercise, did mine today, just have a look at the piccy's I've submitted today, Takes about an hour to do. I used the same 2 gaskets that came off to reassemble with. They are metal shimtype. Much better running.

  6. #6
    Regular Member
    Join Date
    Jan 2009
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks. I saw the carbon deposits from your EGR and lit ooked pretty grim. Glad it worked for you though. I will see how mine is and then post a picture of mine after I have stripped it out tomorrow.

  7. #7
    Regular Member
    Join Date
    Aug 2008
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I did the full strip down of the valve including drilling a 3mm hole in the solenoid and knocking out the plunger which I reassembled with coppergrease. You will need a 13mm spanner, an Allen key 6mm I think and 2 torx bits to take the cover off and strip down the valve itself. Washed my valve with proffessional alloy wheel/trim cleaner and it came up pristine!

  8. #8
    Regular Member
    Join Date
    Jan 2009
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The EGR strip down went well; however, given that my 2005 Signum has an up-to-date service history I was surprised to find the EGR completely choked with carbon. The throttle body was the same, but pleased to say that I followed Jon7278's great thread and pics and my EGR is as good as new. The only problem is that she still only ticks over and won't rev. Nevertheless, I took the punge and called Swindon's Vx main dealer (skurras) and spoke to Chris the Workshop Manager. He told me that if the EGR was that bad the catalytic converter was probably blocked. I procedded to remove the cat and hey presto, she runs like a dream (noisy). Apparantly, I now need to 'regenerate the cat' by driving the car at 60mph for 45 mins in 3rd gear. A little difficult when she won't run with the cat fitted. Ostensibly, a blocked cat' means that the DTF filter is blocked as is the exhaust gas sensor! any ideas anyone - or does it mean a new cat (or 2nd hand one)? Tried to load pictures of EGR, but keeps failing?

    sjmiow61:

  9. #9
    Regular Member
    Join Date
    Aug 2008
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    On a previous vauxhall I owned, the cat was completely blocked also. I removed the cat fro the car set too with it with my power washer and that got it pristine clean and ran brill!

  10. #10
    Regular Member gary k's Avatar
    Join Date
    Feb 2009
    Location
    West Mids/Worcs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bygumlad View Post
    On a previous vauxhall I owned, the cat was completely blocked also. I removed the cat fro the car set too with it with my power washer and that got it pristine clean and ran brill!
    was this a DPF cat or a standard cat?

    many thanks

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. signum 1.9 cdti problems.T
    By bladeage1 in forum Engine & Drivetrain
    Replies: 26
    Last Post: 10th February 2013, 22:12
  2. Signum cdti 150 problems, help anyone?
    By bladeage1 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 9th February 2013, 22:32
  3. Urgent help needed, more signum problems :(
    By Shogun in forum Vectra C / Signum Troubleshooting
    Replies: 23
    Last Post: 29th September 2012, 20:45
  4. Urgent Help Needed please, Signum Elite 2.0T CIM/Dash/Electrical Problems!!!!!
    By robs_gsi in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 28th April 2012, 10:43
  5. Update on Sick Signum CDTI 150
    By signum_1.9 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 9th February 2009, 15:47

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •