User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 21 12311 ... LastLast
Results 1 to 10 of 204

Thread: Swirl flaps Linkage Rod

  1. #1
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Swirl flaps Linkage Rod

    So - just looked at mine this AM (and another CDTI) and the rod has come out of the swirl flaps top... - car is a 2005 CDTI (150).

    Car runs fine, very well actually, so is this a problem..?

    leave it out or try and fiddle about and put it back in...?

    Do the swirl flaps have to be in a certain position when you put the rod back in?

    Cheers

  2. #2
    Regular Member willoftoon's Avatar
    Join Date
    Jun 2008
    Location
    FOREST HALL NEWCASTLE ,,,,,OR DECKHAM ,, ON SUNDAYS .. DINNER TIME MAMMY,S
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    same as mine if its out it has rounded so will just pop back ou tagain sure some 1 did a how 2 using o rings

  3. #3
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Just spent 45 mins trying to get the bl00y thing back in!!! grr - cant get it close!!!

    All swirlflaps are free and movable (except no 3 which I believe is the motorised one).... so just need to get a new linkage bar then I guess if they wear... ?

    Any tips on putting it back on?

  4. #4
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    http://forum.vectra-c.com/showthread.php?t=33511

    try this for the repair, but i could'nt find these exact washers so i got blanks and drilled + glued them and its still ok , must av been 18 mths since !! its fiddly to remove and replace but worth it.

  5. #5
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by the-wizard View Post
    http://forum.vectra-c.com/showthread.php?t=33511

    try this for the repair, but i could'nt find these exact washers so i got blanks and drilled + glued them and its still ok , must av been 18 mths since !! its fiddly to remove and replace but worth it.
    Ah Great!! nice one.

    It certainly isnt effecting the running of the car - running like a dream since I cleaned the EGR..

    So on this fix you file down the bottom of the studs on the rail - or the sides, dont quote get that??

    And where do you stick the washers - at the bottom of the studs, or do you put the stud through the washer??

    thanks in advance

  6. #6
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok ,you remove the rod and just clean up the bottoms where the rod sits onto the flap balls, its only to give a clean surface to super glue the washers to, i put a large piece of sand paper on a flat surface and put the rod onto it to rub all four black bits at the same time to achieve an even surface to all at the same time, i then drilled the blank washers to aprox 6 or 7 mm i think then glued them to all four parts of the rod giving them a top hat look!! (ie glue to where the arrows are pointing in the pic) when dry line up the ball discs and push fit the rod complete with the glued rubbers over the balls, this took a while cos they move and are tricky to line up x4 at once!
    (it does'nt matter if the holes in the rod have gone oval cos when the rubbers are on they will hold the rod onto the balls). and as an after thought thats the word i would use to explain the design, a load of the above.
    Last edited by the-wizard; 14th February 2009 at 18:33.

  7. #7
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Default

    has this got the better of you ant? lol
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  8. #8
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by chrisvectra View Post
    has this got the better of you ant? lol
    Bl00dy thing - tried for ages to put the rod back in - got fed up and gave up in the end lol

    Seems that once they wear its pointless anyway as they will just come back out...

    A

  9. #9
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Default

    wish id not said anything about this now mate lol
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  10. #10
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by chrisvectra View Post
    wish id not said anything about this now mate lol
    hehe - i'm not going to worry to much about it until running is effected TBH..

Page 1 of 21 12311 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Swirl linkage advice please?
    By Gerdo3 in forum Engine & Drivetrain
    Replies: 17
    Last Post: 10th April 2012, 12:52
  2. Swirl Rod Linkage
    By bafoo in forum Troubleshooting
    Replies: 6
    Last Post: 9th July 2010, 16:26
  3. EML was on now off...could it be swirl valve linkage
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 23rd March 2010, 09:14
  4. Swirl flap linkage fallen off but managed to bodge it! (I hope!)
    By jrwilshire2003 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 22nd January 2010, 22:42
  5. Swirl Flap Linkage Rod 'Cheap' Fix
    By AntSSSS in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 1st April 2009, 20:58

Visitors found this page by searching for:

vectra c swirl flaps linkage rod

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •