User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Diesel Pump?

  1. #1
    Regular Member
    Join Date
    Sep 2008
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Diesel Pump?

    Finally took my Vectra C DTI 2.0 into the dealers today, as i have the engine management light on and wanted the code read. Apparently they said it has 19 codes coming up! And they worked through and got it to 9 (without fitting parts? is that possible) and did an ECU update, but could not continue as they had other work on, so i collected the car.

    They said it looks like it is pointing towards the diesel pump? However the car is working fine, starts first time, no black smoke and drives really smooth, the only problem is i cant rev the engine past 2500 as the damn light on! Do you think this could be the problem? Gonna take it to another garage to get their opinion i think! Wish i had asked for the codes that come up!

  2. #2
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    If the car works fine, runs smooth it definitely ISN'T the diesel pump.

    First thing - try cleaning the MAF sensor and check the boost hoses.

    You can check for fault codes yourself:

    Step 1-press brake pedal and hold it
    Step 2-gas pedal the same
    Step 3-insert key and turn the ingition on
    Step 4-the emission light will flash if there is any fault stored in the car's ECU.

  3. #3
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If the eml is on it in limpmode. No acuaters and no turbo thats why it will not rev.


    Wher are located in somerset? I have a snap-on code reader.
    Last edited by sb1uk; 14th February 2009 at 21:51.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. looking for diesel pump x20dtl
    By C-Owner in forum General Chat
    Replies: 0
    Last Post: 6th June 2012, 19:17
  2. Diesel pump
    By ads3 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 9th June 2011, 18:57
  3. Diesel pump???
    By pasty steve in forum Engine & Drivetrain
    Replies: 22
    Last Post: 15th September 2010, 15:34
  4. Need me a diesel pump!!!
    By cov in forum Engine & Drivetrain
    Replies: 5
    Last Post: 20th January 2009, 18:42
  5. diesel pump!
    By littlesxi in forum Diesel Engine related
    Replies: 17
    Last Post: 29th January 2008, 01:15

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •