User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Do HID's really cause so many problems?

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Do HID's really cause so many problems?

    I've only been a forum member AND a Signum owner for a week now. But almost every HID thread I've read and searched seems to throw up all sorts of problems.
    Flickering bulbs, blown bulbs, error readings, short lifespans; they all seems to crop up constantly.

    So are they really that poor? Or do owners who are happy not post, and is it only the problems that are highlighted.
    Does the early pre-facelift, half canbus, cope better than the later models? I have a 2004 Signum.

    I don't need convincing to the benefits of HIDs. I've owned another car for 6 years now that came with HIDs from the factory. And that's the problem, in 6 years I've never had a single problem with them, not even a blown bulb.

    So why all the problems with HID's here? Is it cheap / poor quality products? Can I buy factory units?

    I really do want to fit them, but not if they're going to be problem after problem.

    Any advice on causes of problems, or what units are good or bad would be appreciated.


    David

  2. #2
    Regular Member JSYSH466Y's Avatar
    Join Date
    Dec 2008
    Location
    Newcastle under Lyme
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I brought mine off JAM Performance on Fleabay and not had any probs. No probs with flickering or error messages as they also came with error cancellers included in the £75.
    Very fast service and theres a few threads from people on here who have brought from them. There is also a discount available if you buy outside of ebay.

  3. #3
    Regular Member Morephun's Avatar
    Join Date
    Mar 2008
    Location
    everywhere
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vec c

    Trim : sri

    Engine : 150 cdti

    Year : 55

    Mileage : 108000

    Default

    there are factory fit options very expensive from vxl, I have seen them on ebay once in a blue moon

  4. #4
    Regular Member Danwells72's Avatar
    Join Date
    Jul 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9 cdti 150

    Year : 2004

    Default

    I have some and never had a problem, make sure you get the canbus or digital ballasts

  5. #5
    Regular Member
    Join Date
    Jul 2008
    Location
    Maida Vale
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Some of the problems are down to bad luck, but it's also a case of "you get what you pay for"; some kit that people have purchased plainly won't stop problems such as flickering etc without extra relays being wired in. I didn't want any problems/hassle so bought top end kit (HIDS4U.co.uk "Ultimate" kit) which is guaranteed not to cause any issues with canbus cars, and 8 months on still no problems.

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the reply's so far.

    Anymore thoughts anyone?



    David

  7. #7
    Regular Member MrLOL's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by DavieR View Post
    Thanks for the reply's so far.

    Anymore thoughts anyone?



    David

    the problem with failing HIDs is the proliferation of cheap kits from dodgy places. These are made to a price and as others have discovered, not perform very well.

    Only way around it is to buy a car with xenons as standard (not a usefull suggestion i know) or simply to read around for experiences other users have had, and find a reliable one.

  8. #8
    Regular Member
    Join Date
    Jan 2006
    Location
    carlisle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default hids

    Unfortunately, there's no kit thats guaranteed to work

    I have had 6 replacement ballasts on my ultimate kits from hids4u- and this is their reply to my latest failure

    If another ballast unit has gone within a couple of weeks it
    would indicate that the problem lies with the car and not the
    kit. It is almost unheard of for these ballast units to keep
    going after such a short time. We will of course be happy to
    replace it again however strongly advise you do not use it on
    the Vectra anymore as it would indicate that your particular
    car is not suitable for HID kits


    Best of luck though- I'm going to put the kit on my wife's MG and go back to halogens

  9. #9
    Regular Member Daywalker's Avatar
    Join Date
    Aug 2007
    Location
    Kaunas raj
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Qashqai

    Trim : Visia

    Engine : 1.5dci

    Year : 2010

    Default

    Quote Originally Posted by Danwells72 View Post
    I have some and never had a problem, make sure you get the canbus or digital ballasts
    the problem arises when the ballasts and cancellers aint included.

  10. #10
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well, I've had 2 kits. One was a £250 MTEC kit from several years ago, ran them 18 months without a single issue on my Mk4 and they went with the car when I sold it. My second kit was a £70 kit which blew two bulb and then blew a ballast. 3rd kit is sitting here, a proper MTEC kit with the GE bulbs, and I'm hoping to get a good while from them.

    You get what you pay for IMHO - the £70 kit was poorly made (the screws holding the ballest together were threaded and one fell out when I took the ballast out of the box). The cabling was cheap and nasty too - so bad I used the spare cables I had from my original kit (I ran it using the supplied relay loom so didn't use the other cables). The bulb on the £70 kit had a plastic base and the wires were held in with hot glue. The MTEC kit has proper metal base with high temp plastic fittings.

    HIDs are only worth it if you pay the money for a decent kit like the MTEC kit off HIDS Direct, not the £70 one off JAM (the crap kit I had came from them).

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hid's. 35w or 50w?
    By 2.2 oil burner in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 14th November 2011, 19:03
  2. crusie control problems, anyone had similar problems?
    By rozzer2006 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 2nd October 2011, 21:20
  3. fao EVERYONE with HID's
    By paul_sri150 in forum Vectra C / Signum Car Chat
    Replies: 61
    Last Post: 18th January 2011, 06:44
  4. HID's
    By ahaz123 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 29th December 2009, 20:52
  5. HID's
    By Ziggy in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 7th December 2009, 14:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •