User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: clunks and pings

  1. #1
    Regular Member yorkshireborn's Avatar
    Join Date
    Apr 2006
    Location
    Rotherham SouthYorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SE

    Engine : 2.0

    Year : 2011

    Default clunks and pings

    since the lil snow started im having very funny noises comeing from the nearside wheel it pings and small clunk sounds when i go over small speed bump and grates in the road and when i turn right, but big clunks over big speed bumps now the strange bit sometimes i get no noises at all but a strange kind of tapping like somthing is dangling and hitting the wing.
    yesterday it was really bad with the noises it is getting worse but this morning nothing not a single sound. ive looked under the wheel arch theres nothing i can see no snapped spring no leaking damper no bend arms that i can see.
    any ideas cant afford a garage bill so it will be a DIY job so ill need to be pretty 100% certain wot the noises are b4 i buy the parts needed to fix it.

  2. #2
    Regular Member craigbarlow18's Avatar
    Join Date
    Aug 2008
    Location
    Staffordshire (used to be Newark) And Back to Newark again!!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same ever since snow, makes like a twanging noise on taking up drive forward or reverse and on turning wheel, After a bit of research I think It might be the spring seat problem

  3. #3
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Has the ice melted since? The reason I ask, in severly icey weather, my present car and many that I have owned in the past seem to squeak and groan a lot more. Wait till the weather gets a bit milder and if the noises decrease then you have something to worry about.

  4. #4
    Regular Member vectragsi3.2's Avatar
    Join Date
    Feb 2007
    Location
    cheshire/staffordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    try the drop links mate? they are about 20 quid a pair and are worth doing if they havent been done before!! but if its still doing it it could be the mod on the spring needs doing

  5. #5
    Regular Member baard's Avatar
    Join Date
    Mar 2006
    Location
    Norway
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I just had the same problem with my car, on the right front side. Sometimes the sound was so bad that it sounded as if the spring was broke, when i drove over big holes or speed bumps in the road.

    It is now fixed at my local Opel Garage. It was the front upper spring bearing. (I hope you understand what i mean/my "norwegian -english").

    The mechanic told me that this was a common problem..

  6. #6
    Regular Member craigbarlow18's Avatar
    Join Date
    Aug 2008
    Location
    Staffordshire (used to be Newark) And Back to Newark again!!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine seems to have shut up now its warmer

  7. #7
    Regular Member Driver0069's Avatar
    Join Date
    Oct 2009
    Location
    South Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes mine was doing the same first only some times and the it sounds like you just broke a spring
    when i turn the wheel i could hear bang bang so today got it in the garage and having the upper bearing done the garage has said it is ok now so i am on my way collect.

  8. #8
    Regular Member old cruiser's Avatar
    Join Date
    Jun 2008
    Location
    slough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Driver0069 View Post
    Yes mine was doing the same first only some times and the it sounds like you just broke a spring
    when i turn the wheel i could hear bang bang so today got it in the garage and having the upper bearing done the garage has said it is ok now so i am on my way collect.
    is it sorted now mate?
    Cheers Pete

  9. #9
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Get this on a regular basis as i live in an area where quite a few of the roads have been top coated with chips!, every time i get this its ALWAYS chips getting trapped under the springs, they make weird noises from clunks to boings etc.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clunks when starting
    By mishima in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 23rd February 2010, 17:08
  2. Clunks from rear of car
    By Angelchops in forum Suspension, Wheels & Brakes
    Replies: 12
    Last Post: 5th May 2009, 11:08
  3. Suspension 'Clunks'
    By lofty in forum Vectra C / Signum Car Chat
    Replies: 32
    Last Post: 3rd January 2008, 15:17
  4. Suspension 'clunks' when cold. Anyone got any knowledge.
    By andrewp3883 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 25th January 2007, 23:30

Visitors found this page by searching for:

vectra c spring pinging

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •