User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Climate Control Fan Issue

  1. #1
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Climate Control Fan Issue

    Good People,
    Interesting one this morning - set off as normal (after having scraped snow ,ice of windscreen & windows)
    Put climate control on front window demist and drove as normal, noticed that fan had not slowed down and would not respond to 'manual' the numbers in the display went down but fan kept going.
    Now pulling up at work, turned the ignition off - fan keeps on running - had to remove CC Fuse to stop it - any ideas ?

    SJ

  2. #2
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Try it again and if still doing it sounds like a sticking relay (for full fan speed) - on my A/C only car, going to fan speed 4 activates an additional relay in the glovebox area (from memory)

  3. #3
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Ste View Post
    Try it again and if still doing it sounds like a sticking relay (for full fan speed) - on my A/C only car, going to fan speed 4 activates an additional relay in the glovebox area (from memory)
    Thanks Ste,
    Unfortunately there are no relays - as this is a full climate control spec all done by electronics. I've looked on TIS and suspect its probably the Motor regulator module becoming waterlogged with the melting snow (did have some water in the footwell).
    Anyway I will dismantle and see if I can dry it out / repair.

    SJ

  4. #4
    Moderator & Events Assistant paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : M5

    Trim : Nothing needs adding

    Engine : 5.0 V10

    Year : 07

    Mileage : 37000

    Default

    It might be the resitor pack in the passenger foot well and check the scuttles under the pollen filtewr to make sure they are clear and they tend to block and water comes into the car and soaks the resistor pack.

  5. #5
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Quote Originally Posted by sjanisz View Post
    Thanks Ste,
    Unfortunately there are no relays - as this is a full climate control spec all done by electronics. I've looked on TIS and suspect its probably the Motor regulator module becoming waterlogged with the melting snow (did have some water in the footwell).
    Anyway I will dismantle and see if I can dry it out / repair.

    SJ
    No worries, I saw it was CC, which is why I mentioned mine was A/C - thought maybe there could be a similar arrangement. Clearly not in this case.
    Good luck with fixing it, and if you do, post up your answer to the problem.

  6. #6
    Regular Member
    Join Date
    May 2006
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks People,
    Planning to investigate/dismantle/repair tomorrow, will let you know the gory details

    SJ

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another Climate Control Issue. Help please....
    By Murdoch Troon in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 26th July 2012, 11:14
  2. Climate control temp display issue
    By Greebo in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 30th June 2012, 14:11
  3. 05 Elite Climate control issue
    By graham22vti in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 27th June 2011, 11:41
  4. Climate Control
    By liphook in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 15th December 2008, 04:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •