User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Steering Fault

  1. #1
    Regular Member
    Join Date
    Dec 2005
    Location
    Warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Steering Fault

    Has anyone else had this fault light before:



    The traction control light comes on first, then the steering light comes on. When these are both on the indicators will not cancel. The steering feels fine, it's just really anoying.

    I have spoken to the dealers, and they said they need to see the car when it's in fault as when the ignition is turned off then back on the fault clears I can never seem to get the light on when I go to the dealers.

    Has anyone else suffered with this problem? Sorry for the quality of the photo it was taken with my mobile.

    Thanks all,

    Mark

  2. #2
    On a Sabbatical VauxVeteran's Avatar
    Join Date
    Mar 2006
    Location
    Nicking Ya Dinner.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check the main engine fuse, its one of the big ones that have the high ratings, I had an Omega that did a similar thing yrs ago

  3. #3
    Regular Member
    Join Date
    Dec 2005
    Location
    Warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by VauxVeteran
    Check the main engine fuse, its one of the big ones that have the high ratings, I had an Omega that did a similar thing yrs ago

    But the light does not illuminate all the time.

  4. #4
    On a Sabbatical VauxVeteran's Avatar
    Join Date
    Mar 2006
    Location
    Nicking Ya Dinner.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What actually happened on my Omega was this, all the dash warning lights came on, can ran fine, rev counter and speedo stuck in odd position, its worth a look mate before you enter the world of.......TECH 2 mate you need Tech 2 and £35 to start the ball rolling.

  5. #5
    Regular Member
    Join Date
    Dec 2005
    Location
    Warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by VauxVeteran
    What actually happened on my Omega was this, all the dash warning lights came on, can ran fine, rev counter and speedo stuck in odd position, its worth a look mate before you enter the world of.......TECH 2 mate you need Tech 2 and £35 to start the ball rolling.

    I'll defo give that a look tonight then, because I've already had the other symptoms you said, my rev counter and speedo stuck and all the dashboard lights went out. The speedo unit was replaced, and the dealer said that shoud cure the steering light problem but it never did

    Thanks for that, I'll check later.

    Mark

    Photo of speedo fault:


    As you can see, the car says it's doing about 35mph, not normally a problem, but I was on a carpark with the hardbrake on!!LOL

    I take photo's now everytime I have a fault and give them to the dealers!
    Last edited by biglardyboy; 28th March 2006 at 14:43.

  6. #6
    Regular Member
    Join Date
    Dec 2005
    Location
    Warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Result i think. The fault steering fault happened again today and luckily I was just around the from the dealers. They have at last traced the fault and had to order a new bit.

    So hopefully next week when the car is booked in, this should be the end of the matter.

    Will find out later when I pick the car up what part has to be ordered.

    Mark

  7. #7
    Regular Member
    Join Date
    Dec 2005
    Location
    Warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    A faulty CIM positioning module?

  8. #8
    On a Sabbatical VauxVeteran's Avatar
    Join Date
    Mar 2006
    Location
    Nicking Ya Dinner.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm pleased for you bud, noting more frustrating than no fault found is there.

  9. #9
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm surprised the dealer couldn't look for fault codes via Tech2? All faults should be logged in the ECU surely?

    I'm glad you're sorted though matey.

  10. #10
    Regular Member
    Join Date
    Dec 2005
    Location
    Warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by AJA
    I'm surprised the dealer couldn't look for fault codes via Tech2? All faults should be logged in the ECU surely?

    I'm glad you're sorted though matey.

    And me, but they said nothing was stored

    Mind you nothing would suprise me when it comes to my car!!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering Fault
    By ftm100 in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 26th July 2012, 20:24
  2. Steering Fault
    By samboy143 in forum Suspension, Wheels & Brakes
    Replies: 6
    Last Post: 21st May 2012, 21:16
  3. steering fault
    By andy696uk in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 17th November 2010, 16:22
  4. Steering Fault
    By AOL in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 9th January 2010, 18:41
  5. Steering fault
    By Steven in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 22nd December 2007, 18:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •