User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Have i got EGR Problem?

  1. #1
    Regular Member phil67's Avatar
    Join Date
    Aug 2005
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Exclusive

    Engine : 1.8

    Year : 2005

    Default Have i got EGR Problem?

    This morning my car has been a right pain.

    Its starts ok but is completely flat until it gets to about 2300rpm then takes off like nothing is wrong with it?

    It can not even pull away in second till you get the revs up and a little bit of slipping the clutch.

    Ive tried it with and without the caterman box and there is no difference so would i be looking at an EGR problem?

    Any ideas or help would be appreciated

  2. #2
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It may well be choked up with black crud. Take it off (easy peasy- 13mm socket and a 10mm socket) look inside the manifold where you took it off from and you'll be amazed how much black crud is in there. Clean it out. Split the EGR valve by removing the four torx screws, give the aluminium body a good clean out with brake cleaner and a half inch paint brush. On the end of the EGR solenoid (the black plastic bit) just behind the multiplug connector is a small round piece, drill a small hole in there and use a pin punch and hammer to knock the insides of the solenoid out (there are 3 parts inside including a very fine spring so be careful you dont lose them) oh and it will need quite a sharp tap or two. Clean everything up, oil all the bits and rebuild (you'll have to gently tap the guts back into the solenoid body but don't hit the pin in the centre) put it all back together and be amazed at how your turbo lag has gone

    Oh and if you've used brake cleaner, leave the car for a few hours to let all the brake cleaner evaporate. Otherwise whaen you start it, it will run on the cleaner and you will pap yourself. Turning the engine off and removing the key won't stop it either
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  3. #3
    Regular Member phil67's Avatar
    Join Date
    Aug 2005
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Exclusive

    Engine : 1.8

    Year : 2005

    Default

    Thanks for that, i did have a search and came to think it may be the valve, but what i cant believe it would stop working just like that.

    How long do you think somebody with out much idea will take to do the job?

  4. #4
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Oh about an hour and a half tops. Took me about 45 mins but I do it for a living lol
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  5. #5
    Regular Member phil67's Avatar
    Join Date
    Aug 2005
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Exclusive

    Engine : 1.8

    Year : 2005

    Default

    Thanks Gary

    I will let you know tomorrow how long and how many swear words

    Ohh and what do you place in the hole after it has been drilled and put all back together?

  6. #6
    Regular Member vectra666's Avatar
    Join Date
    Nov 2008
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i got this problem last week. i only read a few threads then followed the above instructions from gary3306.

    car now runs like a dream.
    1 hour max to remove and clean egr, even if you have no mechanical sense

    took me 20 mins

  7. #7
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by phil67 View Post
    Ohh and what do you place in the hole after it has been drilled and put all back together?
    Don't worry about it. It won't hurt but if you do want to seal it, a dab of silicone sealant like what window fitters use.
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  8. #8
    Regular Member phil67's Avatar
    Join Date
    Aug 2005
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Exclusive

    Engine : 1.8

    Year : 2005

    Default

    Thanks Gary

    Lets hope its not raining tomorrow

  9. #9
    Regular Member
    Join Date
    Nov 2007
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you could also try unpluging the egr multiplug to to see if things improve. if they do then egr is faulty and needs a clean.

  10. #10
    Regular Member phil67's Avatar
    Join Date
    Aug 2005
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Exclusive

    Engine : 1.8

    Year : 2005

    Default

    Update

    I managed to do this job yesterday (Saturday) and i would like to say thankyou for everyones advice / ideas and a bigger thanks to Gary3306 who was spot on with the time to do the job?

    It runs like a dream again.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rear Signum Light problem problem - help
    By scw02102 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 8th July 2012, 21:12
  2. Wiper Electrical Problem? (Not sticking or cold weather problem)
    By SRIAdam in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 7th July 2012, 16:13
  3. 1 problem sorted and 1 more problem arises
    By bunsen1 in forum Engine & Drivetrain
    Replies: 22
    Last Post: 4th April 2011, 13:03
  4. Bit of a problem, Need Help
    By vectrasri-j in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 18th January 2010, 19:21
  5. Problem...? Vectra SXI...problem with starting after filling with fuel?
    By doozer in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th November 2008, 09:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •