User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Broke one of the pollen filter clips

  1. #1
    Regular Member PeterVV's Avatar
    Join Date
    Oct 2007
    Location
    south wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Broke one of the pollen filter clips

    will I have to resort to superglue, or is there any way of replacing the clip?

  2. #2
    Regular Member yorkshireborn's Avatar
    Join Date
    Apr 2006
    Location
    Rotherham SouthYorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    not unless u can get a replacement from scrappys

  3. #3
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Mine has sat in my GSI for 12 months now with no clips on at all. The size of the pollen filter means it's wedged in the hole and the absence of the clips makes no difference to how it performs.

  4. #4
    Regular Member Daywalker's Avatar
    Join Date
    Aug 2007
    Location
    Kaunas raj
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    One of my clips was broken so i used an elastic band

  5. #5
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by gtr1000 View Post
    Mine has sat in my GSI for 12 months now with no clips on at all. The size of the pollen filter means it's wedged in the hole and the absence of the clips makes no difference to how it performs.
    Yep, mine is broke as well but it sits nicely, another alternative to an elastic band as someone mentioned on here is to use a bit of foam to wedge it in.

  6. #6
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    I had the same problem, and I sorted it by wedging half a small rawlplug upside down in front of the clip. It works well as the rawlplug has a slit from the open end which fits nice and tight over the metal edge of the pollen filter housing, and butts up to the clip. Without it the pollen filter was hanging out of the housing on one side. Glad to know I wasn't the only one with this problem. The clips are so flimsy and easily broken.

  7. #7
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    They are like milk chocolate, mines just wedged in.

  8. #8
    On a Sabbatical
    Join Date
    Jan 2009
    Location
    Plymouth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i nearly broke mine this morn when inspecting the filter.... they are so soft its unreal!

    On a side note i was checking the filter as apparently it was replaced when it was serviced 2k miles ago..... I dont think so... back to the garage 2moro for me!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clips holding pollen filter
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th November 2012, 15:55
  2. pollen filter
    By nokiaman1978 in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 11th July 2011, 12:55
  3. pollen Filter
    By gibbon7000 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 29th March 2009, 21:44
  4. Pollen Filter retaining clips - rubbish quality
    By wickedwillie in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 9th June 2008, 16:18
  5. Pollen filter
    By parapaul in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 30th October 2007, 20:34

Visitors found this page by searching for:

pollen filter clips

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •