User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Diesel 2.2 SRi Not starting

  1. #1
    New Member
    Join Date
    Jan 2009
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Diesel 2.2 SRi Not starting

    Hi Guys

    2003, 03 2.2 litre DTi Veccy SRi, not starting. Not my car yet, but should be very soon.

    I'm buying it as a project and intend to get it running.

    Only facts known are:

    1) Car details above

    2) 130k miles

    3) Running fine one evening, wouldn't start the next and hasn't started since.

    4) Dealer have allegedly diagnosed a faulty diesel pump but no idea how they've come to that conclusion.

    My questions:

    What is this problem likely to be?

    If it is the diesel pump, is it possible for someone fairly competent DIY to change it? (I Can change Omega V6 head gaskets and rebuild heads, that's about my level).

    Is the pump married to any of the ECUs or have an inbuilt ECU etc etc etc and what issues are there in fitting a pump off another car? (new will be silly money) - or could I Get the existing one repaired?

    I have easy access to a real Tech2 - would anything else be needed?

    I really like the Veccy C, having had one as a hire car, so I would be over the moon to get this car and get it running!

    Cheers all!

    James

  2. #2
    Regular Member
    Join Date
    Jan 2009
    Location
    bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it is married to ecu . and it will be pump ive got same prob on my 2.2 dti sri you need a new pump which is blank and can be programed which takes around an hour to program

  3. #3
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My mate had this problem. VX told him pump at fault- it was crank sensor its worth trying that first. I have has 2 2dto omega and vectras and had no problems with pumps. I may even be leak off pipes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 diesel vectra not starting
    By vectrahunter in forum Engine & Drivetrain
    Replies: 12
    Last Post: 17th June 2012, 20:41
  2. starting a 1.9 diesel
    By tyler boy in forum Engine & Drivetrain
    Replies: 35
    Last Post: 2nd April 2011, 23:41
  3. Diesel engine starting
    By jacko52 in forum Diesel Engine related
    Replies: 7
    Last Post: 6th January 2010, 21:53
  4. Starting a diesel car...
    By macdad in forum Vectra C / Signum Car Chat
    Replies: 43
    Last Post: 4th January 2010, 18:18
  5. Diesel Starting Tips Please
    By MRLUBBERLUBBER in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 24th October 2008, 01:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •