User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Does Faulty EGR cause less MPG?

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    Leicestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Does Faulty EGR cause less MPG?

    Hi All,

    I guess the info I want will be somewhere on this great site amonst all the EGR valve posts...but I cant find it!

    My veccy seems to be drinking more diesel and at the cost I dont like it, also I think performance is a bit down, and at first start up tick over isnt the smoothest! Generally the car does go ok.

    I have had the swirl valve done, then the 3rd injector was done.....is it the EGR now? What checks can I easily do?

    In regard to the spanner light, this does come on when I turn on the iginition but goes out straight away...is this a current fault or an old one that needs clearing?

    I get fed up and keeping paying the stealer for Tech2 etc and hoped that I could maybe be brave and clean/replace the EGR. Also what the cheapest way to get / clear codes?

    Thanks......markluk

  2. #2
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    EVERYWHERE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    At idle and on full load or full throttle the EGR valve should be closed.If it is stuck even slightly open (carbon deposits can easily cause this) the fuel mixture for each of those will be affected causing a rough idle and loss of power at high engine loads/speeds.Cleaning the valve will usually cure this (there is an 'how to' for that somewhere?).

    Many local non-franchise garages can clear codes,so it's not always necessary to get ripped off by the stealers.

  3. #3
    Regular Member Avenged's Avatar
    Join Date
    Oct 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by markluk View Post

    In regard to the spanner light, this does come on when I turn on the iginition but goes out straight away...

    does that on everycar!
    it's just the car making sure everything works!
    all the lights come on the dash when you turn on the ignition and the one's that don't need to stay on aftera few seconds.. go!


  4. #4
    Regular Member big rich's Avatar
    Join Date
    Nov 2008
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra gsi

    Trim : Full heated leather

    Engine : 3200

    Year : 2004

    Default

    Quote Originally Posted by markluk View Post
    Hi All,

    I guess the info I want will be somewhere on this great site amonst all the EGR valve posts...but I cant find it!

    My veccy seems to be drinking more diesel and at the cost I dont like it, also I think performance is a bit down, and at first start up tick over isnt the smoothest! Generally the car does go ok.

    I have had the swirl valve done, then the 3rd injector was done.....is it the EGR now? What checks can I easily do?

    In regard to the spanner light, this does come on when I turn on the iginition but goes out straight away...is this a current fault or an old one that needs clearing?

    I get fed up and keeping paying the stealer for Tech2 etc and hoped that I could maybe be brave and clean/replace the EGR. Also what the cheapest way to get / clear codes?

    Thanks......markluk
    im only in brum, i have a fault code reader your welcome to use if you fancy a drive down ...just a thought save you paying out

  5. #5
    Regular Member bgm46's Avatar
    Join Date
    Sep 2006
    Location
    South Queensferry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Avenged View Post
    does that on everycar!
    it's just the car making sure everything works!
    all the lights come on the dash when you turn on the ignition and the one's that don't need to stay on aftera few seconds.. go!

    This is only after a fault has logged, will continue to happen for a few weeks and if the fault has not shown again then it clears.
    It will not show up under normal start if there has not been a fault.

    There is a prob if it comes on whilst driving

  6. #6
    Regular Member
    Join Date
    Aug 2008
    Location
    Leicestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not sure if I should have tagged this onto this post but hey!....

    My Veccy has now had money spent on her, new rear brakes, full service and MOT - all good so far!

    The service and MOT was all done last Tuesday and when I picked here up she was like new again - all the power back

    The engine management light was cleared as part of the service - but this came back on during startup after 150 miles or so - AND - I think the power has gone back down again

    I am trying to get hold of a code reader - had a U480 delivered but that has gone back as it didnt work - I should be getting another sent as I thought it was faulty (or could it be incompatible withe my car??).

    If anyone can shed some light on this I would be grateful - and whether a U480 is compatible with a 2005 (could be 2004 manufactured) 1.9cdti 150 Energy.

    Thanks, Mark

    PS - I dont know what the MPG is like post service but it was down to 41mpg prior to the service.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Faulty MAF (I think)
    By gerryo in forum Engine & Drivetrain
    Replies: 5
    Last Post: 3rd March 2012, 14:08
  2. Faulty maf
    By Mattle40 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 16th January 2012, 23:21
  3. faulty speedo
    By trickyjacks.4 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 1st August 2011, 15:37
  4. Faulty lpg
    By mark88 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 11th January 2010, 19:44
  5. faulty tps
    By Morephun in forum Engine & Drivetrain
    Replies: 3
    Last Post: 13th February 2009, 21:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •