User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: loss of power, any suggestions????

  1. #1
    Regular Member mat100edt's Avatar
    Join Date
    Nov 2008
    Location
    south coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default loss of power, any suggestions????

    i have a 2ltr turbo edt 100.
    was driving home tonight and everything was fine, travelled about 10 miles up the motorway at about 80 (70 if your a police officer) came off at my juction, stopped, pulled away again and it was sluggish as hell. It still moved but felt really slow, it didnt seem to limit itself to any speeds, just spent ages to get there lol. The dump valve wasn't as loud so at first i thought it was a boost problem, although turbo stil sounded ok ie. whistling and spinning up ok. so i thought maybe a split hose, dodgey vacum hose, popped my head under bonnet when i got home and all seemed ok. so went and had my dinner then took it for a drive again and all seems ok.

    weird!!!!!

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like a lost of boost pressure/sensor getting a reading it didn't like and going it 'safe' mode. Not limp mode, but basically the turbo drops down to minimum boost. Usually resets itself when you restart the engine.

    Given the fact that you've fitted a dump valve I'd be looking at that as the likely culprit.

  3. #3
    Regular Member mat100edt's Avatar
    Join Date
    Nov 2008
    Location
    south coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    well something like that did cross my mind. the dump valves been on there for around 3 months with no probs.

  4. #4
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Keep an eye on it then - it may have just been a once off.

  5. #5
    Regular Member mat100edt's Avatar
    Join Date
    Nov 2008
    Location
    south coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers for your help mate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Need more power on a budget - 2.0 DTI (suggestions please)!!
    By Vaux-Man-G in forum Diesel Engine related
    Replies: 3
    Last Post: 17th September 2012, 15:10
  3. 2L DTI '53 Loss of Power
    By BigTunz in forum Engine & Drivetrain
    Replies: 17
    Last Post: 3rd November 2011, 17:27
  4. Loss of power
    By Silentknight in forum Engine & Drivetrain
    Replies: 7
    Last Post: 6th October 2009, 15:51
  5. loss of power
    By jonnynufc in forum Engine & Drivetrain
    Replies: 8
    Last Post: 15th May 2009, 00:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •