User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: 2.2 16v - Idle Problem

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2 16v - Idle Problem

    My car seems to drop revs steeply when I depress the clutch....instead of dropping to 750rpm it falls to 500rpm then slowly picks back up to 750rpm without any problems.....it drives fine but does this everytime!
    Any ideas would be great.... It's a 53' with 100k on the clock.
    Thanks

  2. #2
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Clean the Tb mate, when it closes it should leave a tiny sliver for the air for tick over to get through. 2.2 are well known to cover there TB's in cr@p and the gap is restricted, the EGU will then open the butterfly to stop it stalling. I recon a good old clean with some carb cleaner will sort it. HTH

  3. #3
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thats great....thanks......

  4. #4
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ......cleaned the T/B with wd/40 and a toothbrush!!!!!!!
    Also cleaned the EGR valve and is now idling perfect......the EML did come on so not sure if it's just some crap I've disturbed.....so disconnected the battery to reset it and it's stayed off..... up to now anyway...

  5. #5
    Regular Member Tadpole's Avatar
    Join Date
    Dec 2008
    Location
    'I haven’t lost my marbles, they’re in a bag somewhere? .. '
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like you've cracked it m8. ... for now.

  6. #6
    Ex Vec-C Admin & Founder Graeme's Avatar
    Join Date
    Jun 2005
    Location
    SCOTLAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nice one mate sounds like a result.

    Out of interest for a mechanical dimwit - ME - anybody got a pic of the tb's and the egr valve and how to remove them for a clean up. I am doing an oil change and taking the k+n filter out to clean up and maybe fitting a vxr air intake next couple of weekends so could do this at the same time.

  7. #7
    Regular Member
    Join Date
    Jan 2009
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This is the EGR valve...it's located at the right handside of the block as you stand at the front of the car......just 2 bolts and a metal gasket.And this is the throttle body.......

  8. #8
    Ex Vec-C Admin & Founder Graeme's Avatar
    Join Date
    Jun 2005
    Location
    SCOTLAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Superb mate thats great.

  9. #9
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Graeme, for out 2.2's we can just block them off. VX do a blanking plate, think its about £4 from memory. You remove the EGR, put the blanking plate over the hole, nip it up and all done. Keep the EGR plugged into the loom and the valve will still open and shut so the ECU will think all is hunky dory, the ECU only monitors that the EGR is physically opening and shutting, it doesn't monitor gasses. To keep it all tidy hank the EGR by one bolt off the blanking plate. If you want to take it a step further than VX will Tech 2 the hole system out for you and deleting it is the VX fix for a duff EGR on the 2.2 petrol.



    EGR for 2.2 on battery side of the block (barrel shaped thing)



    Blanking plate.
    Last edited by rushy; 16th February 2009 at 22:07.

  10. #10
    Regular Member
    Join Date
    Feb 2008
    Location
    norn iron
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi rushy, is it the same set up for the direct? mine looks different!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle problem
    By speedfreeride@yahoo in forum Engine & Drivetrain
    Replies: 0
    Last Post: 6th June 2009, 19:15
  2. idle problem
    By speedfreeride@yahoo in forum Engine & Drivetrain
    Replies: 1
    Last Post: 3rd June 2009, 00:30
  3. 2.0T idle problem
    By peteopc in forum Engine & Drivetrain
    Replies: 8
    Last Post: 24th April 2009, 19:35
  4. Idle problem
    By Spelly in forum Engine & Drivetrain
    Replies: 9
    Last Post: 20th January 2009, 00:08
  5. Idle problem?
    By dawn brown in forum Engine & Drivetrain
    Replies: 20
    Last Post: 16th January 2008, 01:50

Visitors found this page by searching for:

vauxhall vectra 2.2 sri not running right on idle

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •