User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Heater only blowing cold air

  1. #1
    Regular Member
    Join Date
    May 2008
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater only blowing cold air

    Hi Guys, could use some advice on my heater issue.

    Car was toasty warm on the way home tonight so turned the heater to cold, now it wont go back to warm.

    Took the car out again later to see if it was a temporary glitch but no such luck. Its blowing air on all settings and the engine temp is showing normal within a couple of miles 85-90 ish so am i right in thinking this isnt the thermostat because the engine temp is ok?

    Anyone got any ideas on the most likely offending item? Im thinking its either the mixer servo, a blocked heater matrix or some kind of actuator problem for the mechanism that directs the warm air to the vents.

    Thanks

  2. #2
    Regular Member
    Join Date
    May 2008
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Fixed it - the mixer servo was jammed - gave it a push and its workig again, i wont be surprised if it sticks again though and I have to get a new one.

  3. #3
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    Which one is the mixer servo? Did you need to remove the glovebox to get to it.

  4. #4
    Regular Member mat100edt's Avatar
    Join Date
    Nov 2008
    Location
    south coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if you mean by mixing servo, the control valve that controls how much ho water goes through heater (prob monted in bulk head) then you should be able to take th small stepper motor off the side of it, give it a wash through with wd40 and put it back together.

  5. #5
    Regular Member
    Join Date
    May 2008
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by ed taylor View Post
    Which one is the mixer servo? Did you need to remove the glovebox to get to it.
    Yes thats the one on the LHSide of the centre console - had to take out the glove box to get the panels in the footwell out.

    I could see the servo thing twitching when i moved the temp dial so I gave it a push and something clicked and its working again - well for now anyway.

  6. #6
    New Member
    Join Date
    Nov 2009
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hello guys,
    I have same problem on my 02 1.8 petrol vectra.
    I take the glove-box out and when im switching cold/hot on the control panel i see how the red arm is moving. On position "cold" its blowing very cold air, when i switch on "not" its blowing a bit warm, but its still very cold in the car.
    I search the forum form weeks but still cant find a solution.
    Today change the antifreeze, and everything looks fine there,the pipes are worm, but still blowing cold air.
    Any advise is welcome, because im planing a trip to eastern Europe and there is freezing.
    Thanks in advice.

    p.p. The thermostat work fine

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Air con blowing cold
    By malcwit in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 23rd May 2012, 13:37
  2. Aircon not blowing cold
    By Ralphwells1967 in forum Vectra C / Signum Troubleshooting
    Replies: 7
    Last Post: 14th September 2011, 22:38
  3. Vectra LS blowing cold air only
    By andy64 in forum Vectra C / Signum Troubleshooting
    Replies: 9
    Last Post: 23rd January 2011, 18:04
  4. heaters not blowing cold
    By andyman201 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 12th January 2010, 18:29
  5. Heater blowing cold.
    By neilgsi in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 6th December 2008, 17:48

Visitors found this page by searching for:

vectra c heater blowing cold

vauxhall vectra heater not blowing hot

vectra c ac blows cold on one side and hot on the other

vectra c heater only blows cold

vectra c heater servo

vectra c blowing cold air

vectra c no heating

vectra c 04 heater blow cold air when on hot

vauxhall vectra heater only blowing cold air

vauxhall vectra heating blowing cold

zafira heater only blows cold

vectra heater blowing cold

vauxhall insignia no hot air

vectra heater blowing cold air

vauxhakl signum heaters working on cold onlyvectra c not switching between hot and coldvectra elite heater not getting hotvauxhall vectra 05 plate 1.8 blowing cold airzafira heater blowing cold airvectra c heater blower coldvectra elite heater not blowing hot airvauxhall vectra blowing cold airvauxhall omega rear heater cold1998 vectra 2.5 blowing cold airNo hot air blowing in my vectra c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •