User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Vectra 2.2 dti estate 2004 stalling/spanner light

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    Newmarket
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra 2.2 dti estate 2004 stalling/spanner light

    Hello, I'm new to this forum so Hello to everyone.

    I've just bought a Vectra 2.2 DTI estate 2004 from a private dealer last Saturday with a 6 month Motorcare Warranty.

    During the week it has "stalled" twice when coming to a stop, but today it became an actual problem when I turned into my road after a 40 mile trip and it cut out with spanner light and then would only start for a few seconds at a time and had to coast into my parking space. There was also a knocking sound present.

    I've taken the day of work tomorrow with the intentions of at least getting it to a garage for repair. I was going to ring the Warranty company so that I know the required procedures and then the garage in the morning. I will then ring my breakdown company to come and have a look and hopefully follow me to the garage if they cant fix it.

    I've been reading the threads this week about stalling, but was wandering if someone could give me some advice on the possible problem or tips on my planned morning??

    Thanks in advance.

    Andy

  2. #2
    Regular Member Graham's Avatar
    Join Date
    Sep 2005
    Location
    Macclesfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Focus

    Trim : Titanium

    Engine : 1.6 TDCI

    Year : 62

    Mileage : 9K

    Default

    Firstly welcome to the forum.
    Ive not got a cure for you sorry, not very technical myself, but know how you feel when your pride and joy goes wrong. I think what youve said already, get it to a garage so they can read the fault code.
    Then contact the warranty company with the fault and repair price.
    Good luck tommorrow.

  3. #3
    Regular Member
    Join Date
    Jan 2009
    Location
    Newmarket
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the welcome and the reply

    I'm not that technical myself, just wanted some pointers in the right direction.

    Andy

  4. #4
    Regular Member Danwells72's Avatar
    Join Date
    Jul 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9 cdti 150

    Year : 2004

    Default

    Check all the boost hoses incase they are split, clean the egr valve, check the oil and clean the boost sensor.

    I had massive problems with both of my boost hoses and decided to change them for metal ones. My car behaved sort of like yours by spanner light and lack of power but never stalled. I cleaned the egr valve and it worked a treat! not had problems since.

    I would recommend and engine flush and oil change unless you have put new oil in.

  5. #5
    Regular Member
    Join Date
    Jan 2009
    Location
    Newmarket
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hello Danwells72, sorry I didnt reply sooner, but have been googling/haynes your reply.

    If the fault comes up as the EGR valve, it doesnt look to big a problem to clear out (or hopefully cost to much).

    Just 1 questiion if I decide to clean it myself, how would you actually clean it and with what? Is it all metal or anything delicate?

  6. #6
    Regular Member John35's Avatar
    Join Date
    Jun 2007
    Location
    in a white box
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check out the HOW2's posted the link below.

    http://www.vectra-c.com/forum/showthread.php?t=60856

  7. #7
    Regular Member Danwells72's Avatar
    Join Date
    Jul 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 1.9 cdti 150

    Year : 2004

    Default

    Quote Originally Posted by XXXArlow View Post
    Hello Danwells72, sorry I didnt reply sooner, but have been googling/haynes your reply.

    If the fault comes up as the EGR valve, it doesnt look to big a problem to clear out (or hopefully cost to much).

    Just 1 questiion if I decide to clean it myself, how would you actually clean it and with what? Is it all metal or anything delicate?
    disconnect the electric socket attached, 2 Inverted torx screws, wiggle it out gently. use the how 2 to clean it

    EDIT: I used an old toothbrush to clean mine with
    Last edited by Danwells72; 11th January 2009 at 21:09.

  8. #8
    Regular Member
    Join Date
    Jan 2009
    Location
    Newmarket
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Now I'm just dazed and confused

    Rang up a local garage this morning to see if they would take on the car. Breakdown guy didnt check the car, just towed it to the garage.

    Rang up garage at 5 to see if he had looked at it and he said there were no errors on the reader. Absolutely nothing!!

    Just 2 things I didnt mention on first post was that I replaced the Air cleaner filter on Sunday morning and put a bottle of Injector cleaner in the tank.

    Would the Injectors cause the cutting out problem and the cleaner cause the major problem I had when coming home?? If not what else could be wrong with no fault codes. (still got cleaning the EPG up my sleeve, but mechanic didnt think it was related to the cutting out)

    Thanks in advance

    Andy

  9. #9
    Administrator plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    359 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    tbh it sound more like a fueling problem. Either its losing to the injectors ie the pump not injecting it which could be a crankshaft sensor or similar or something really simple like you've got crap in the fuel lines/fuel filter and it needs changing. Worst way is the pump but lets not go there yet...

    EGR would give rough running at low rpms or good low rpms and crud performance

    If it was boost hoses you'd still have a good idle but bog all performance over 1500rpm or so with it holding back and then the EML would come on.

    Some of the solenoids which control boost/ air inlet switchover valve and a cpl of others i cant think of are controlled by a vacuum pump. If certain hoses are split they wouldnt always cause an EML to come on.
    Last edited by plasma; 12th January 2009 at 20:08.

  10. #10
    Regular Member
    Join Date
    Jan 2009
    Location
    Newmarket
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hello, thanks for the reply.

    I'll try and clean out the EGR this week and see if that helps. Only had it a week, so not to sure if the performance is incorrect. Although 1st to 2nd does seem a bit whiney (but thats only comparing it to my petrol Ibiza)

    Would the Injector Cleaner put the dirt through the pipes till its clear or am I on the wrong track there?

    (Sorry if I'm asking to many questions as a new user, but I'm losing confidence in the car pretty quickly)

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 30000 revs spanner light .limp mode .vectra 2.0 dti 2004
    By davemander in forum Engine & Drivetrain
    Replies: 7
    Last Post: 19th February 2013, 00:07
  2. Vectra 2004 ls dti spanner light help!!
    By jediknight in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 15th September 2009, 09:44
  3. Vectra 2004 ls dti spanner light
    By jediknight in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 14th September 2009, 19:20
  4. Vectra CDTI Spanner Light-2004
    By Vaux-Man-G in forum Vectra C / Signum Troubleshooting
    Replies: 18
    Last Post: 20th May 2008, 15:21
  5. 05 Vectra Estate Life 1.9 CDTI 120 Spanner light keeps coming on
    By themagpie in forum Engine & Drivetrain
    Replies: 20
    Last Post: 23rd March 2008, 17:23

Visitors found this page by searching for:

vectra c 1.9cdti spanner light and stalling

Vauxhall signum 2.2 dti spanner light keeps coming on

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •