User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Signum 1.9cdti Sluggish at Low Revs

  1. #1
    Regular Member
    Join Date
    Jul 2008
    Location
    North West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Signum 1.9cdti Sluggish at Low Revs

    HI All,

    Hope someone can help me with this one?
    Had my Signum since July and recently started to experience a lack of acceleration at low revs.
    Particularly noticeable when setting off is really slow till it hits about 2000 rpm then kicks in fine. From then on , through the revs /gears no problem.

    The car is 3 years old in March (52K miles)so want to get it sorted before the warranty expires. Any ides before the garage tell me, 'Oh they all do that,sir'!

    Cheers
    Steve

  2. #2
    Regular Member cameraman's Avatar
    Join Date
    Sep 2006
    Location
    Leicester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Looks like another EGR valve this was yesterdays! http://www.vectra-c.com/forum/showthread.php?t=66287

  3. #3
    Regular Member ditchp's Avatar
    Join Date
    Jan 2007
    Location
    The world famous city ground
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    when was it last serviced ???
    Midlands Mod Shop - NFFC.

  4. #4
    Regular Member big rich's Avatar
    Join Date
    Nov 2008
    Location
    birmingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by cameraman View Post
    Looks like another EGR valve this was yesterdays! http://www.vectra-c.com/forum/showthread.php?t=66287
    i would put money on it being the egr m8

  5. #5
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Gutless Vectra

    I hired a vectra 1.9 150bhp vectra with only 200 miles on it . Pulling away Into traffic was dangerous just would not go below 2000rpm.

  6. #6
    Regular Member pugs,signum's Avatar
    Join Date
    Mar 2008
    Location
    swansea
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by spj555 View Post
    HI All,

    Hope someone can help me with this one?
    Had my Signum since July and recently started to experience a lack of acceleration at low revs.
    Particularly noticeable when setting off is really slow till it hits about 2000 rpm then kicks in fine. From then on , through the revs /gears no problem.

    The car is 3 years old in March (52K miles)so want to get it sorted before the warranty expires. Any ides before the garage tell me, 'Oh they all do that,sir'!

    Cheers
    Steve

    take a look at this thread and see if your car is suffering with swirl valve problem! as my car started with a lack of power under 2000rpm turned out its the swirl valves but guttinly for me i have no warranty and the 1.9cdti (150) engines are prone to swirl valve failure will be doing the job myself to save hundreds of £ss as it dont come cheap!

    http://www.vectra-c.com/forum/showth...ght=glow+plugs

  7. #7
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Swirl valve, EGR or turbo!

  8. #8
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I'm betting swirl valves jammed open.

  9. #9
    Regular Member pugs,signum's Avatar
    Join Date
    Mar 2008
    Location
    swansea
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I took mine to a garage and they put it on laptop to check egr and that was fine (was hoping it was EGR as that would be the cheapest to replace lol) also check out the airflow meter as thats meant to give some touble with power heres a thread how to check it.

    http://www.vectra-c.com/forum/showth...=airflow+meter

  10. #10
    Regular Member Drew's Avatar
    Join Date
    Jun 2008
    Location
    Sedgefield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Just had the inlet manifold changed on mine for the new one and the car is like new again. Except the EGR is showing faulty now and wasn't before the change (I will be checking it's connections tomorrow). Check the swirl flaps yourself there is a thread on here or get the dealer to do it. Mine were that worn at 81,000 that they were lifting on their axis and letting all the boost out so it would not pull below 2500rpm. As a consequence the Diesel particle filter was sick and showing a fault and that was putting the car into limp mode, it's now fine.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sluggish revs and white smoke
    By n8sby in forum Engine & Drivetrain
    Replies: 1
    Last Post: 2nd July 2012, 16:19
  2. Sluggish Performance with Signum 1.9 CDTI
    By flensberg in forum Engine & Drivetrain
    Replies: 3
    Last Post: 1st May 2010, 08:59
  3. 2.0T sluggish 1500K-2K revs ?
    By moorlander in forum Engine & Drivetrain
    Replies: 5
    Last Post: 17th August 2009, 01:18
  4. no wonder the 1.9cdti 150ps are a bit flat at low revs
    By solorider in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 11th February 2009, 12:18
  5. Replies: 4
    Last Post: 12th December 2008, 12:47

Visitors found this page by searching for:

sinum diesel sluggish

no boost on low rews 1.9cdti

Signum slugish at low revs

vauxhall 2.0 cdti sluggish

vauxhall signum diesel sluggish

vectra c 1.9cdti sluggush

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •