User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 9 123 ... LastLast
Results 1 to 10 of 83

Thread: Vectra 3.0 CDTI engine code problem

  1. #1
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra 3.0 CDTI engine code problem

    Can anyone help . I have a 3.0 CDTI Vectra 04.

    Put you foot on throttle restricted resonce, let foot up put down again and away it goes no problem.

    When it cruises at about 1500rpm it gets a hesitation but if you accelerate it stops.

    When cold car ticks over ok on tickover when warm EML comes on code PO105 Pressure Boost Sensor.

    Have replaced EGR, Flywheel , And Pressure Boost Sensor.

  2. #2
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If I go from start. it will not go passed 2000rpm. if you blip throttle it picks up and accelerates normal .

    if you pull away quick going uo through the gears it accelerates fine. That because you a bliping the throttle when you change gear. But as soo as you let your foot off and cruise it starts to histate like mad . put food down nothing happens ,blip throttle and accelerate its fine again.

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Is the turbo 100%? if the sensor isn't seeing the right boost levels it may flag up a sensor issue but it could be not seeing what it should due to the turbo not performing.
    Now I need a turbo to keep up!

  4. #4
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Any splits in the boost pipes

  5. #5
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have checked pipes . I have replaced every Sensor on the car. I am trying to get my hands on a secondhand turbo at the moment from a saab or vectra as they are both the same.

  6. #6
    Regular Member 30ltr nutter's Avatar
    Join Date
    Sep 2007
    Location
    dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi this is what i found it could be electrical and not pressure related
    P0100 Mass Air Flow Sensor Circuit Low Input C-07
    P0100 Mass Air Flow Sensor Circuit Range/Performance C-07
    P0105 Boost Pressure Sensor Circuit High Input C-08
    P0105 Boost Pressure Sensor Circuit Low Input C-08
    P0105 Boost Pressure Sensor Voltage Supply Circuit High Input C-08
    P0105 Boost Pressure Sensor Voltage Supply Circuit Low Input C-08
    P0115 Engine-Coolant Temperature Sensor Circuit High Input C-09
    P0115 Engine-Coolant Temperature Sensor Circuit Low Input C-09
    P0115 Engine-Coolant Temperature Sensor Circuit Range/Performance C-09
    P0190 Mechanical Fault in Fuel System (Partial Load) C-14
    P0190 Mechanical Fault in Fuel System (Full Load) C-14
    P0195 Engine Oil Temperature Sensor Circuit High Input C-10
    P0195 Engine Oil Temperature Sensor Circuit Low Input C-10
    P0400 Exhaust Gas Recirculation Circuit High Input C-16
    P0400 Exhaust Gas Recirculation Circuit Open C-16
    P0400 Exhaust Gas Recirculation Flow Excessive Detected C-16
    P0400 Exhaust Gas Recirculation Flow Insufficient Detected C-16
    P0500 Vehicle Speed Sensor Circuit High Input C-22
    P0500 Vehicle Speed Sensor Circuit Incorrect Signal C-22
    P0500 Vehicle Speed Sensor Circuit Range/Performance C-22
    P0560 System Voltage Low Input C-03
    P0606 Replace Control Unit C-02
    P0703 Brake-Light Switch Circuit Incorrect Signal C-11
    P0703 Brake-Light Switch Circuit Incorrect Signal (Ignition On) C-11
    P0704 Clutch Switch Input Circuit Malfunction C-12
    P0725 Engine-Speed Sensor Input Circuit Incorrect Signal C-18
    P0725 Engine-Speed Sensor Input Circuit no Signal C-18
    P0725 Engine-Speed Sensor Input Circuit Signal Range/Performance(Overspeed) C-18
    P1110 Variable Intake Air/Variable Swirl (Diesel) High Input C-17
    P1110 Variable Intake Air/Variable Swirl (Diesel) Circuit Open C-17
    P1125 Boost Pressure Solenoid Valve High Input C-15
    P1125 Boost Pressure Solenoid Valve Circuit Open C-15
    P1125 Boost Pressure Solenoid Valve Excessive Flow Detected C-15
    P1125 Boost Pressure Solenoid Valve Insufficient Flow Detected C-15
    P1180 Fuel Temperature Sensor Circuit High Input C-14
    P1180 Fuel Temperature Sensor Circuit Range/Performance C-14
    P1220 Injection Timing Control Excessive/Insufficient Flow Detected C-14
    P1335 Injection Pump: no Engine Speed Input Signal from Control Unit C-18
    P1345 Injection Pump: Camshaft Speed Malfunction C-14
    P1501 Immobiliser Not or Wrong Initialised C-05
    P1502 Immobiliser No Signal C-05
    P1503 Immobiliser Wrong Signal C-05
    P1515 Pedal Position Sensor Circuit High Input C-06
    P1515 Pedal Position Sensor Voltage Supply Circuit High Input C-06
    P1515 Pedal Position Sensor Voltage Supply Circuit Low Input C-06
    P1515 Pedal Position Sensor Potentiometer Error C-06
    P1515 Pedal Position Sensor Brake Switch Error C-06
    P1515 Pedal Position Sensor General Error C-06
    P1530 A/C Compressor Cutoff Relay Primary Circuit High Input C-21
    P1530 A/C Compressor Cutoff Relay Primary Circuit Open C-21
    P1560 System Voltage High Input C-04
    P1560 Injection Pump: System Voltage Range/Performance C-04
    P1604 Replace Control Unit C-02
    P1604 Replace Control Unit C-02
    P1604 Variant Coding Wrong Code Programmed C-02
    P1604 Variant Coding Not Programmed C-02
    P1620 Replace Control Unit C-02
    P1620 Replace Control Unit C-02
    P1625 Power Supply Relay Switched Off too Late C-04
    P1630 Fuel-Injection Quantity Circuit High Input C-14
    P1630 Fuel-Injection Quantity Malfunction C-14
    P1631 Replace Control Unit Injection Pump C-14
    P1631 Replace Control Unit Injection Pump C-14
    P1631 Replace Control Unit Injection Pump C-14
    P1631 Replace Control Unit Injection Pump C-14
    P1631 Replace Control Unit Injection Pump C-14
    P1631 Replace Control Unit Injection Pump C-14
    P1631 Replace Control Unit Injection Pump C-14
    P1635 Glow Device Circuit High Input C-19
    P1635 Glow Device Circuit Open C-19
    P1635 Glow Device Circuit General Error C-19
    P1650 CAN: Device Offline C-14
    P1650 CAN: Device Hangup C-14
    P1651 CAN Receives Error C-14
    P1651 CAN Transmits Error C-14
    P1651 Injection Pump: CAN Malfunction C-14
    P1660 Fuel Cutoff Solenoid Valve Circuit High Input C-14
    P1660 Fuel Cutoff Solenoid Circuit Open C-14
    P1660 Fuel Cutoff Solenoid Valve Malfunction C-14
    P1690 Malfunction Indication Lamp (MIL) Circuit High Input C-24
    P1690 Malfunction Indication Lamp (MIL) Circuit Open C-24
    P1694 Glow Time Telltale Circuit High Input C-25
    P1694 Glow Time Telltale Circuit Open C-25

    --------------------------------------------------------------------------------

  7. #7
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Thanks for the codes.

    I have all the codes on the VX tis. My snap on scanner flages up p0105 pressure boost sensor range and performance.

    I have changed this sensor but still the same.

  8. #8
    Regular Member 30ltr nutter's Avatar
    Join Date
    Sep 2007
    Location
    dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    that code could mean many things u will have to start at the basics check the intercooler and pipe work ect check that u have vacumn at the boost control on top of the turbo. i had the same code when the intercooler pipe came off and it will do the same if a pipe has got a small hole in it. because it says sensor it does not allways mean its the sensor it just means the fault lies in that part of the system

  9. #9
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi thanks for that. I will check the pipes again before replacing turbo.

  10. #10
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by 30ltr nutter View Post
    that code could mean many things u will have to start at the basics check the intercooler and pipe work ect check that u have vacumn at the boost control on top of the turbo. i had the same code when the intercooler pipe came off and it will do the same if a pipe has got a small hole in it. because it says sensor it does not allways mean its the sensor it just means the fault lies in that part of the system

    Another thing I did not mention is that the hesitation is there when stopped just reving the engineto about 1600rpm.

Page 1 of 9 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 CDTi - Have you had a problem with this engine or not?
    By Ian in forum Vectra C / Signum Car Chat
    Replies: 233
    Last Post: 19th June 2013, 14:18
  2. engine code for vectra vxr
    By george1987 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 29th March 2010, 19:20
  3. P0700 Engine ECU Code Vectra 1.8 Auto 2001
    By Laura in forum Troubleshooting
    Replies: 1
    Last Post: 29th May 2009, 19:40
  4. Cdti 150 Engine Problem
    By scad2k in forum Troubleshooting
    Replies: 8
    Last Post: 25th August 2008, 21:31
  5. V6 CDTi faulty engine problem update
    By willc01 in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 14th June 2007, 21:20

Visitors found this page by searching for:

vectra c 3.0 cdti p0105

3.0cdti p0105

3.0cdti p0105 boost sensor

vectra 3.0 cdti problems

3.0 cdti nothing happens full throttle

vauxhall vectre 3.0 cdti

error p0105 vectra c 3.0 cdti

vectra c 3.0 v6 cdti engine number

p0700 signum z30dt

opel 3.0 cdti engine number

P1501 Immobiliser Not or Wrong Initialised C-05 how to fix

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •