User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: no power

  1. #1
    Regular Member
    Join Date
    Dec 2008
    Location
    Law Village, Carluke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default no power

    Just wondering if some one can help me please my vectra seems to have a loss of power its not a significant loss but it is noticeable there is no warning lights on or any indication the is some thing wrong she just does not pull like she should 1.9cdti [150]

    Any help or advice would be much appreciated
    Thanks

    also read about the fuel injector by merikilto could this be part of the problem i am having

  2. #2
    Regular Member
    Join Date
    Oct 2007
    Location
    Gloucester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    From what you've said it may well be the EGR valve. Mine's just been replaced as have many others. Search EGR valve and have a browse through the posts.

  3. #3
    Regular Member
    Join Date
    Dec 2008
    Location
    Law Village, Carluke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default fao bigknill (no power)

    thanks very much bigknill will look into that and will let u know

  4. #4
    Full Member spennny's Avatar
    Join Date
    Jun 2008
    Location
    Blantyre
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have a 2.2 Direct SRI 06 plate, does mine have one of these EGR thingy's or are they diesel only..... yeah i know, nOOb question !!!

  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Spenny, yes i think it does.
    Now I need a turbo to keep up!

  6. #6
    Regular Member
    Join Date
    Jun 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Spenny, Yup I believe they all have them. It's an Exhaust Gas Recirculation Valve. I'm thinking of getting a blanking plate for my 1.8 Sxi Veccy as they apparently run better without them.

  7. #7
    Regular Member
    Join Date
    Dec 2008
    Location
    Law Village, Carluke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi guys

    where do i get a blanking plate for the egr valve and is it any good like what does it do is there any pros and cons getting it done

  8. #8
    Regular Member
    Join Date
    Jun 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry the only ones I've seen don't mention the desiel engines.

    http://cgi.ebay.co.uk/EGR-Valve-Blan...1%7C240%3A1318

    There are a few threads on here that discuss the option of blanking off the EGR Valve. Try a search in the trouble shooting section.

  9. #9
    Regular Member
    Join Date
    Dec 2008
    Location
    Law Village, Carluke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks mate will take a look have sent message to seller if it does fit 1.9cdti [150] will post reply if anyone else is interested cheers and thanks for the link much appreciated
    Last edited by vectraC.elite1.9.150; 29th December 2008 at 21:12.

  10. #10
    Regular Member
    Join Date
    Dec 2008
    Location
    Law Village, Carluke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    had a reply the blanking plate is not for the diesel engines sorry

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Troubleshooting
    Replies: 6
    Last Post: 6th June 2011, 18:55
  3. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Troubleshooting
    Replies: 0
    Last Post: 5th June 2011, 11:30
  4. Replies: 11
    Last Post: 7th January 2010, 17:50
  5. Power Steering Electrical Power Drain
    By AntB in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 1st November 2007, 16:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •