User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Cdti 150 no power

  1. #1
    Regular Member
    Join Date
    Oct 2006
    Location
    ayrshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    rolleyes Cdti 150 no power

    Hope some of you guys can help,

    Just had the car recovered home

    Was driving to do a bit of shopping today, the car was fine, it a 05 150 vectra by the way,

    Suddenly when going to accelarate normaly the car had no power,
    stopped the car and attempted to pull away, car will rev but very very slowly and once it gets to 3000rpm it goes like stink again

    So in brief car goes like normal but only over 3000 rpm

    No lights on and is a bit lumpy when about 2000 rpm

    can you help

  2. #2
    Moderator & Events Assistant paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : M5

    Trim : Nothing needs adding

    Engine : 5.0 V10

    Year : 07

    Mileage : 37000

    Default

    It is either the EGR valve which works below the 2000 rpm turbo cut in point or it is the number 3 fuel injector wiring loom, the later sounds scarey but is a loot cheaper. Check this thread out.

    http://www.vectra-c.com/forum/showth...njector+wiring

    Mine had the same problem but the EGR was fine but you can clean it yourself and save a shedload of cash check it out here

    http://www.vectra-c.com/forum/showth...t=egr+cleaning

    http://www.vectra-c.com/forum/showth...t=egr+cleaning

  3. #3
    Regular Member
    Join Date
    Oct 2006
    Location
    ayrshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks mate will have a look

  4. #4
    Regular Member
    Join Date
    Oct 2006
    Location
    ayrshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cleaned out the egr valve and cleaned all connectors on the fuel injection, also made sure and cleaned the swirl connections onto of the head, cleared the fault light and away it went, so good so far!!!!!


    thanks for your help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No power from 1.9 cdti 150
    By garetmcc79 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 1st April 2012, 08:04
  2. 1.9 cdti 150 no power
    By baz_cdti_sri_150 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 3rd October 2010, 15:00
  3. little power 150 cdti
    By smokydiesel in forum Engine & Drivetrain
    Replies: 13
    Last Post: 26th May 2010, 19:13
  4. 150 cdti with no power
    By pauly in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 7th January 2009, 00:23
  5. 150 Cdti down on power??
    By shrekster in forum Engine & Drivetrain
    Replies: 0
    Last Post: 7th December 2008, 00:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •