User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: 1.9 CDTi 120. EGR, Swirl Valve or ???

  1. #1
    Regular Member
    Join Date
    Dec 2008
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused 1.9 CDTi 120. EGR, Swirl Valve or ???

    Hi all
    Thank god I found your forum. Have found some good info and given me a sense of direction! Still have a problem tho and would love to have some advice from some better minds than mine! Would really appreciate some help.

    Bought a Signum 1.9 CDTi (2006) about 4 months ago and was delighted with it. It now has 109K on the clock but its the only way I would afford a facelift model!

    Problem started 2 weeks ago, loss of power at times, drove like it had 'lumpy' fuel in it. Popped to the local garage who put some 'gunk' in the tank but it made no difference.

    Problem was getting worse and the spanner light came on so back to the garage. They had a new Solus Pro machine and read error code P2279 (intake air system leak). They cleared the code and put more 'gunk' in the tank.
    No improvement.

    Back to the garage but they couldn't find a leak in the hoses. When carrying out the throttle solenoid valve test - the vehicle stalls.

    Found your site and info suggested 'swirl valve' which I passed on to the mechanic. He found that the valve was open and would close during the test. Admitted he was no expert but thought that was the wrong way round...Any Ideas please???

    Back on your forum and see that the EGR could be the problem (now it's gettin scary). Some said its easily cleaned and I'm thinking it may be best to clean this first as the swirl valve looks like lots of cash which I can ill afford at this time of year.

    Symptoms in brief:

    Sometimes drives well, sometimes s***e.
    Began being worse on first start and improved when left running for 5 mins but now seems to have little or no correlation with engine temp.
    Worse at low and high speeds.
    Service incl fuel filter change made no difference.
    Strong smell of diesel at times.
    A hiss can now be heard on accelleration (slow on the uptake I know, but I mend people not cars!)
    Spanner light on only sometimes.
    The engine warning light came on and stayed on once until cleared by the garage.

    I was going to go to the stealers but after reading your threads I'm sure they're no better than anyone else and they charge a fortune for the priviledge. My local garage are good and honest I would love to be able to give them some clues!!!

    Many many thanks for reading this story, I hope there's a wise man out there!

    Happy christmas to all forum members.

  2. #2
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like a split in an intercooler pipe, or indeed a hole in the intercooler.

  3. #3
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    No.3 injector I think, it sound like it is firing on 3 cylinders. Would explain smell of diesel.

    check this thread out and it should solve your problem if your engine number falls into the batch quoted

    http://www.vectra-c.com/forum/showthread.php?t=62925
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  4. #4
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Its a well know issue from VX and for causing jerking I think they should include total engine shut down!


    Field Remedy: 2049
    Subject: Engine Z19DT/H - Jerking, somtimes Trouble Code P0201-P0204 set
    Models: Engines: Option:
    Vectra-C 2004...2006,Signum 2004...2006,Astra-H 2004...2006,Zafira-B 2005...2006 Z19DT| Z19DTH| Z19DTL,Z19DT| Z19DTH| Z19DTL,Z19DT| Z19DTH| Z19DTL| Z19DTJ,Z19DT| Z19DTH| Z19DTL
    Complaint: Customer complaint about jerking sometimes SVS lamp on and DTC P0201-P0204 set.
    Cause: Software and / or fretting corrosion on injector plug.
    Production: Modified wiring harness has been implemeted in production as of engine numer: Z19DTH17000444.

    Remedy:
    In case of customer complaint reprogram ECU according TSB 1849 before changing any parts.
    If TSB 1849 will not cure the problem install field fix injector plugs (partnumber 93189918 / cataloguenumber 62 86 769).
    Mentioned Field fix kit does not contain of a 1,5mm² wire as mentioned in TIS 2000 wiring diagram.
    In case of concern please use 2,5mm² instead.
    FunctionalGroup: J - Engine
    Complaint Group: 06 - Failure Code Setting by Control Unit
    Trouble Code: P0201,P0202,P203,P204
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  5. #5
    Regular Member
    Join Date
    Dec 2008
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for replying so quickly guys.

    I'll take your answers to the garage and def let you know what happens next!

    Appreciated

  6. #6
    Regular Member mattolly86's Avatar
    Join Date
    Nov 2008
    Location
    oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i know on the 8v cdti 120 there is no swirl valves sounds like hole in intercooler to me

  7. #7
    Regular Member
    Join Date
    Dec 2008
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    still struggling on...
    garage didnt seem to think this was caused by hole in intercooler/pipe, tho dont know how hard they looked! thought I'd try the 3rd injector and went to the local stealers. chap said he'd never heard of problem which inspired me with confidence straight away. He spoke to a mechanic who said it was'nt a common problem but had done 2 before. then just to p**s me off completely said this part had to come from Germany and quoted £444 + VAT. scuse my mechanical ignorance but this forum suggests a replacement is between £11 and £90. Am I mixing things up???

    unfortunately being close to christmas, time was running out and it was booked in the local garage early after the festive period.

    then things got drastically worse when the car suddenly lost nearly all power and could'nt get up a hill; tons of black smoke out the exhaust and some from under the bonnet. home on a low loader.

    after christmas, at the garage they found the cat to be completely blocked and this had blown a pipe off. they cleaned it out refixed the pipe, quick test drive and made my day. next day, WTF, original problem back again.

    does this give any more clues to help me out guys? do I take it that whatever the underlying probem is, this causes the cat to coke up? thinking of getting them to clean the EGR next as looking again all over this site - symptoms look similar. very poor in low revs then suddenly (but sometimes after a while) turbo cuts in and were off like a rocket!

    your advice again would be very appreciated.

  8. #8
    Regular Member
    Join Date
    Nov 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As far as i'm aware the problem isn't with the injector itself but the wiring to number 3 (counting from the left as you look at the engine).The wiring kit is fairly cheap, no harm in getting the EGR valve cleaned but first on my list would be to look at the injector wiring to number 3 cylinder.

  9. #9
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm still thinking a boost pipe/intercooler issue. The cat could have clogged with the soot from running rich, due to a lack of air.

    When my 1.9CDTi popped a hose (wasn't tightened on enough when I put the decat pipe on), it filled the road with smoke, it was like a ferry boat starting off.

  10. #10
    Regular Member
    Join Date
    Dec 2008
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks guys
    I'll get it in for them to check the intercooler/pipes properly and look at inj no 3 and perhaps clean the EGR while their at it!

    Shrekster
    sorry but could you tell me exactly what I need to order for the no 3 wiring or even a part number. and what would I expect to pay? just a little concerned as the local vaux dont seem to have any idea and might well take the pee...

    thanks again

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 CDTi Swirl Valve Issue
    By Ninj in forum Engine & Drivetrain
    Replies: 23
    Last Post: 12th November 2012, 20:33
  2. CDTI Swirl Valve
    By leeds vectra in forum Vectra C / Signum Car Chat
    Replies: 43
    Last Post: 25th March 2011, 18:12
  3. CDTi 150 Swirl valve thing !?!?
    By mark_647 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 17th May 2009, 21:05
  4. 1.9 CDTi Swirl valve
    By djr69uk in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 27th August 2008, 16:14
  5. CDTI Swirl Valve revisited
    By chrish in forum Engine & Drivetrain
    Replies: 3
    Last Post: 26th August 2007, 11:44

Visitors found this page by searching for:

throttle solenoid valve astra 1.9cdti replacement

vectra c 1.9 cdti 120 egr

vectra c 120 swirl flaps

vauxhall 1.9 rough egr or swirl

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •