User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: can anyone suggest where to start..throttle position sensor

  1. #1
    Regular Member
    Join Date
    Nov 2008
    Location
    glenrothes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default help me.......... throttle position sensor.fault code

    vectra 1.9cdti 55 plate eml light came on ..... egr cleaned along with pipe and the area egr bolts on to. problem solved! now the spanner light is coming on had the fault read and cleared a few times the problem coming is throttle position sensor..please help me David
    Last edited by leeboy; 8th December 2008 at 15:51. Reason: forgot model

  2. #2
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    A friend of mine had this problem too....never got it sorted but here is the THREAD I started for him.

    May/may not help. Sorry cant be more help at the mo, hope you get it sorted soon!


    Bye bye Vec B
    - Hello Siggy!

  3. #3
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    The TPS is the accelerator position sensor. There will be a potentiometer attached to the acc pedal. It could be misconnected, damaged or dirty.

  4. #4
    Regular Member
    Join Date
    Nov 2008
    Location
    glenrothes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default can anyone suggest where to start..throttle position sensor

    can anyone give me some pointers where to start on my 55 plate vectra cdti 150bhp.....eml light came on, cleaned the egr, problem solved... now the spanner light on. the code keeps coming up is throttle position sensor. the box on the the throttle pedal seems to be a sealed unit......................please help David.

  5. #5
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    It is not compulsary to start a new thread everytime. You can just reply to your existing threads on this....

    Have you removed it and done anything with it? I am sure you could try spraying electrical contact cleaner into it and moving to the extremes of it's travel to clean the internals before condemning it. Maybe it is fooked, and the only thing to do would be get a new one? Maybe a scrapper can provide one more cheaply than VX, but then you are not sure what you are getting.

  6. #6
    Regular Member
    Join Date
    Nov 2008
    Location
    glenrothes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default sorry!! still learning with this forum

    which code reader do i have to buy to clear the codes on my 55 plate cdti. bought one last week from ebay thinking it would be ok when it's not!! wasted money and time.

  7. #7
    Regular Member
    Join Date
    Nov 2008
    Location
    glenrothes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default is there anyone there????????????????

    has anybody had the same throttle sensor fault? and could it be anything else other than the sensor on the acc pedal? someone said during the week it could be leak in a vaccum hose not wanting to spend any money on the wrong cure. any help would be great. by the way i have a dtuk box fitted

  8. #8
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    I really can't see why vacuum pipe leak would trigger TPS sensor fault.

  9. #9
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Ste View Post
    It is not compulsary to start a new thread everytime.
    Lee, as Ste said, you can just continue in the original thread you started. I've now merged all three threads together.
    Quote Originally Posted by leeboy View Post
    by the way i have a dtuk box fitted
    First thing I would do is remove any tuning box if you're having fault codes/problems etc. That way you can at least see if it's the box, or not, that is part of the problem.

  10. #10
    Regular Member
    Join Date
    Nov 2008
    Location
    glenrothes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default the spanner light

    how does the spanner light work? if the problem is solved would you still get the spanner light on for few secs when you turn on the ignition or does it clear on it's own? just so i know what looking for. thanks

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. throttle position sensor
    By Ryan in forum Engine & Drivetrain
    Replies: 7
    Last Post: 24th November 2010, 21:06
  2. Throttle Position Sensor
    By RichyA in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 23rd September 2010, 15:12
  3. Throttle Position Sensor...
    By GazVXLINE170 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 16th September 2010, 20:51
  4. Throttle Position Sensor
    By Kristypie in forum Engine & Drivetrain
    Replies: 1
    Last Post: 9th April 2010, 21:14
  5. throttle position sensor
    By Morephun in forum Engine & Drivetrain
    Replies: 2
    Last Post: 3rd July 2008, 10:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •