User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Loud creaking from front of car

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    linlithgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Loud creaking from front of car

    This is my first post and I'm hoping someone can help diagnose the loud creaking/crashing noise I'm getting whenever I go over a speed bump. It sounds like it is from the front shocks but it doesn't make any noise when turning the wheels on full lock.

    I have used the search function but didn't find a definitive answer. It could be shock absorber related or anti roll bar bushes or drop links etc.

    The car is a 2002 Vecta C 1.8 LS

    Any help greatly appreciated

    Mike

  2. #2
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the creaking could be a drop link which has gone dry aswell as knocking, they aren't that expensive, so best bet is to get then checked out

  3. #3
    Regular Member simon1's Avatar
    Join Date
    Oct 2007
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia elite tourer vxline biturbo

    Trim : Elite vxline

    Engine : 2.0 biturbo

    Year : 2013

    Mileage : 80000

    Default

    more like the anti roll bar rubbers as well only about a fiver from vx

  4. #4
    Regular Member CDTi Mike's Avatar
    Join Date
    Dec 2005
    Location
    Melksham, Wiltshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My issue with the same sound was the radiator mounts, i'm sure I read there are some modified ones available from VX.

  5. #5
    Regular Member
    Join Date
    Aug 2008
    Location
    linlithgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by simon1 View Post
    more like the anti roll bar rubbers as well only about a fiver from vx
    How big a job is it to fit these?

  6. #6
    Regular Member
    Join Date
    Nov 2008
    Location
    glenrothes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default please help

    hi mate, i'm a new user to this website can you tell me how to post a new thread? can't seem to see new thread button anywhere. thanks David.

  7. #7
    Regular Member mark_w's Avatar
    Join Date
    Sep 2008
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by CDTi Mike View Post
    My issue with the same sound was the radiator mounts, i'm sure I read there are some modified ones available from VX.
    a guy at work with a 2.0T had this problem, that was rad mounts.

  8. #8
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : ELITE

    Trim : FULL LEATHER

    Engine : 1.9 CDTI 150 BHP

    Year : 2004

    Mileage : 87,000

    Default

    Quote Originally Posted by CDTi Mike View Post
    My issue with the same sound was the radiator mounts, i'm sure I read there are some modified ones available from VX.
    this sounds like my problem , Mike it could be your strut top bearings

  9. #9
    Regular Member Graham's Avatar
    Join Date
    Sep 2005
    Location
    Macclesfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Focus

    Trim : Titanium

    Engine : 1.6 TDCI

    Year : 62

    Mileage : 9K

    Default

    Quote Originally Posted by leeboy View Post
    hi mate, i'm a new user to this website can you tell me how to post a new thread? can't seem to see new thread button anywhere. thanks David.
    Go back to the car chat page and on the top left hand side is a button ( new thread) that will do it.

  10. #10
    Regular Member
    Join Date
    Aug 2008
    Location
    linlithgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by peadar View Post
    this sounds like my problem , Mike it could be your strut top bearings

    To be honest, the noise sounds like it is coming from that area. Are these an easy/cheap fix?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loud creaking noise from servo area ?
    By simac in forum Suspension, Wheels & Brakes
    Replies: 3
    Last Post: 6th December 2015, 02:35
  2. Very loud creaking noise from front suspension
    By ROCKATANSKY in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 9th January 2011, 22:20
  3. Handbrake making loud plastic/creaking noise
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 27th October 2010, 18:29
  4. Creaking from front
    By johnmac in forum Suspension, Wheels & Brakes
    Replies: 6
    Last Post: 8th December 2008, 22:16
  5. Creaking from front - 03 1.8 SXI
    By addyboy1982 in forum Suspension, Wheels & Brakes
    Replies: 24
    Last Post: 13th June 2007, 21:14

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •