User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: rear windscreen problem.

  1. #1
    Regular Member TKD Colin's Avatar
    Join Date
    Jan 2008
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default rear windscreen problem.

    I just spent half an hour cleaning and polishing the inside and outside of my rear windscreen in an attempt to stop it fogging up. 15 minutes later after I finish the front the rear is completely fogged up again.

    Anyone got any tips on how to stop the windscreens from fogging up?

  2. #2
    Regular Member bobby-tupper's Avatar
    Join Date
    Nov 2008
    Location
    LEEDS, W.YORKS
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 07 Estate




    Default

    same here,its taking a life time to clear even with the heated screen on!!

  3. #3
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    I don,t think there is much you can really do this weather. I have tried that " anti mist" stuff, and I found it to be a waste of time.

  4. #4
    Full Member neverlandandy's Avatar
    Join Date
    Sep 2006
    Location
    lanark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Elite Nav

    Trim : Elite

    Engine : 2.0 cdti

    Year : 2012

    Mileage : 9k

    Default

    iv tried the anti mist stuff myself too and also found it to be rubbish so iv decided to just put up with it

  5. #5
    Regular Member blues n twos's Avatar
    Join Date
    Sep 2008
    Location
    Seer Green, Bucks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It will mist up worse and quicker if you have a damp boot.

    A lot of vectra's leak at the back and this will cause a lot of misting up especially this time of year as well.

    If you have a nice dry boot then im talking cr*p

    Jon

  6. #6
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Never had a problem with that on my Signum - does it even fog up when you have the heated screen on? If so then it sounds like damp as others have said.

  7. #7
    Regular Member Small Racer's Avatar
    Join Date
    Jan 2008
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like damp - vec c suffers lots via the rear hatch
    If used on short distance and inside of car not warmed up just adds to the problem.
    Check for damp in the boot - wheel well and or rear carpets etc.
    Put a couple of newspapers in the boot and on floor in the rear passenger foot wells - should help draw the damp down.
    Cars with a/c should not suffer as the a/c should dry out the air.

  8. #8
    Regular Member wanna veccy's Avatar
    Join Date
    Nov 2007
    Location
    telford,
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    make sure that your pollen filter isn't past its best and if u are using a fabric freshner like fabreze i would recomend u stop as they make my vec mist up like a beatch. also use the air con to dehumidify the air that is in the car too.hth

  9. #9
    Regular Member TKD Colin's Avatar
    Join Date
    Jan 2008
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the responses guys,

    I will check the boot and so on for damp but i'm pretty sure its gonna be dry as ive never had a problem with damp before and I dont use any sprays in the car so that shouldn't be a problem.

    The screen does clear with the rear heater on but it takes forever.

    Think i'll try putting something in the back to absorb the moisture in the air and see how that goes.

    The pollen filter shouldnt be a problem as it was changed when the car was service in may.

    Thanx Colin.
    Last edited by TKD Colin; 7th December 2008 at 18:46. Reason: missed a bit

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rear Windscreen repair
    By Veccy55 in forum Bodywork & Interior
    Replies: 0
    Last Post: 23rd December 2012, 16:13
  2. rear windscreen heat fix
    By leedslads in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 16th September 2012, 20:02
  3. windscreen wiper problem
    By dean79 in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 6th February 2011, 15:25
  4. windscreen wiper problem
    By dean79 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 5th February 2011, 20:05
  5. Windscreen washer problem
    By heheshamon in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 7th February 2010, 14:54

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •