User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Heater blowing cold.

  1. #1
    Regular Member neilgsi's Avatar
    Join Date
    Aug 2005
    Location
    Peterborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater blowing cold.

    Hi Guys

    My GSI has started blowing cold though the vents. I have checked all fuses and water/oil levels all fine. I then took off glovebox and lower passenger trim. I can see a servo controller a blue and black arm which both work fine along with the lower servo with red control arm. This goes up and down fine and turn to full extension when changing from LOW to HIGH (climate control).

    As i missing anything, is there another servo ? Had a look through all the threads but am now stuck .

    cheers

    neil

  2. #2
    Regular Member big rich's Avatar
    Join Date
    Nov 2008
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra gsi

    Trim : Full heated leather

    Engine : 3200

    Year : 2004

    Default

    try your thermostat is not locked shut....worth a try

  3. #3
    Regular Member myhotholden's Avatar
    Join Date
    Sep 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does the enigine temp reach the normal operational temp?

    If it does, and stay at the same temp, then odds are the thermostat is functioning / opening and closing fine as the engine would overheat if it was stuck closed.

    Is there decent coolant flow?, check the header tank (expansion tank) for coolant flow when the engine is running, i know that seems unusual if the engine temp is ok, but, the coolant needs to flow correctly through the entire cooling system for the heaters to work correctly, you may have a block in the heater matrix causing it to be cold.

    Does the heat come out of the demister vents, or is air just cold through all of the vents?
    If it is hot through the screen demister and cold through the dash vents you may have a blend motor problem.

    If you have electronic climate control, then it may be a fault with the climate control panel.

    Try getting it Tech2'd or go to an auto diagnostic centre and have the codes read on the cooling and electrical system.

    Hope something easy and cheap works out for you mate.
    Last edited by myhotholden; 6th December 2008 at 15:01. Reason: grammar

  4. #4
    Regular Member neilgsi's Avatar
    Join Date
    Aug 2005
    Location
    Peterborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers for the fast responses, im going back out to brave the cold later to check some other bits out

  5. #5
    Regular Member 900ss's Avatar
    Join Date
    May 2008
    Location
    Bucks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you do get stuck I think I still have a spare heater control panel from an 03 GSI
    Your welcome to try before you buy, if that helps you out?
    If it does it's £20 if you want it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Air con blowing cold
    By malcwit in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 23rd May 2012, 13:37
  2. Aircon not blowing cold
    By Ralphwells1967 in forum Vectra C / Signum Troubleshooting
    Replies: 7
    Last Post: 14th September 2011, 22:38
  3. Vectra LS blowing cold air only
    By andy64 in forum Vectra C / Signum Troubleshooting
    Replies: 9
    Last Post: 23rd January 2011, 18:04
  4. heaters not blowing cold
    By andyman201 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 12th January 2010, 18:29
  5. Heater only blowing cold air
    By Chilie in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 23rd December 2009, 18:26

Visitors found this page by searching for:

vauxhall insignia heater blowing cold

vectra c heater blowing cold

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •