User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Bit of help please (Turbo Boost Control Fault)

  1. #1
    Regular Member
    Join Date
    Aug 2007
    Location
    Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Bit of help please (Turbo Boost Control Fault)

    Hi there,

    ok, the story:

    For the past 3 or 4 weeks ive noticed that instead of the ususal 43-45mpg i am used to, i have only been getting 38-40mpg. Now, i just put this down to my driving but last saturday the Engine management light came on and the car went into limp mode. (no biggie, i pulled over, turned the engine off and it didnt come back on). Now, ever since then ive noticed that my Revs seem to be higher than usual (over 2000rpm when doing 70mph).

    I took it to a guy who got the fault code up and (cant remember exactly what it was) he said it was a 'Turbo Boost pressure control' Fault.

    He cleared the fault and said to try it and see if there was any difference. There wasnt. I've got it booked in at Vauxhall on monday but will they be able to find the fault since it has been cleared? also, what is the problem likely to be?

    P.S, it's a 53 Plate 2.2dti SRi

  2. #2
    Regular Member AndrewTi's Avatar
    Join Date
    Feb 2006
    Location
    Guttedsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Boost sensor will need cleaning for a start, from there it could be split hoses on the turbo or intercooler, or vacuum pipes split or perished.

    Check them all thoroughly yourself, cleaning the boost sensor is easy enough. 8mm ring spanner, bottle of carb cleaner and a small long bristled brush.

    Remove the sensor, liberally spray it and aggitate it GENTLY with the brush. Allow to dry and refit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. boost control solenoid
    By viper8 in forum Engine & Drivetrain
    Replies: 37
    Last Post: 14th January 2013, 00:22
  2. Boost control with actuator arm
    By tomo41 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 22nd July 2011, 08:24
  3. turbo boost fault 30ltr cdti
    By 30ltr nutter in forum Engine & Drivetrain
    Replies: 2
    Last Post: 10th May 2011, 00:28
  4. Turbo Boost Control Valve?
    By stupottyuk in forum Engine & Drivetrain
    Replies: 0
    Last Post: 20th July 2010, 12:59
  5. boost presure control
    By cambis9 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 2nd April 2008, 17:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •