User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: problem with my Car

  1. #1
    New Member
    Join Date
    Nov 2008
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default problem with my Car

    Hi

    whilst driving last night, for some reason my battery light came on, then whenever i accelorated all the warning lights started flashing and at times even turned all the electrics off

    my speedo etc all stopped working too...

    i parked the car up and now this morning the battery is completely flat

    before last night, ive had no probs with the car or any signs of a problem.

    Any one know what could have happened or likely costs to get this sorted

    the car is 98 VECTRA ARCTIC 16V AUTO

    thanx in advance

    Leon

  2. #2
    Regular Member videodoctor's Avatar
    Join Date
    Apr 2007
    Location
    Blackpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It sounds like the alternator has gone kerput.Also i think your in the wrong forum as this is for the vectra 'c' where as yours is a vectra 'b'.(older shape).

  3. #3
    Regular Member MRLUBBERLUBBER's Avatar
    Join Date
    Dec 2006
    Location
    North Lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Don't be like that videodoctor the lad's only asking bless him. When we've got him up and running then's the time to tell him to shove off onto his own car site Ha! Ha!

  4. #4
    Regular Member shan's Avatar
    Join Date
    Dec 2006
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry I'm not mechanically minded mate.
    Quite a few people on here have still got Veccy B's mate I'm sure at least one of them will be along to help you out with some info.
    Bump for u.

  5. #5
    On a Sabbatical
    Join Date
    Dec 2007
    Location
    south wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could be alternator as your speedo is electri not cable i think,on my calibra when alternator went if i turned lights off i has power turned lights on now power,would be worth waiting for a few posts though mate as there is a lot of knoledge on this forum

  6. #6
    Administrator plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    434 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    I recently changed an alternator for a Vec B 'P' reg 1.8 petrol.. Cost me £20 from the breakers and changed it in just under 2hrs.... It does sound like the alternator to me... But get your local garage to check it first, probably charge you about 1.5hrs labour plus £60-80 if you go for a recon alternator

  7. #7
    Regular Member blues n twos's Avatar
    Join Date
    Sep 2008
    Location
    Seer Green, Bucks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As said above....

    The easiest way to check for alternator is with a battery charge tester. Or decent multi meter.

    With the conections on both terminals of the battery it should show say 14v to 16v with engine running if alternator is ok.

    If alternator is not pushing a charge into the battery it will show 12v or slightly less.

    hth's Jon ex Vectra B owner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rear Signum Light problem problem - help
    By scw02102 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 8th July 2012, 21:12
  2. Wiper Electrical Problem? (Not sticking or cold weather problem)
    By SRIAdam in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 7th July 2012, 16:13
  3. 1 problem sorted and 1 more problem arises
    By bunsen1 in forum Engine & Drivetrain
    Replies: 22
    Last Post: 4th April 2011, 13:03
  4. Bit of a problem, Need Help
    By vectrasri-j in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 18th January 2010, 19:21
  5. Problem...? Vectra SXI...problem with starting after filling with fuel?
    By doozer in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th November 2008, 09:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •