User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: 1.9cdti Lack of power

  1. #1
    Regular Member
    Join Date
    Feb 2008
    Location
    Tarbert
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.9cdti Lack of power

    Hi i have a 1.9cdti and today have noticed today a severe lack of power before the trbo kicks in. Once the turbo cuts in everything seems fine but is really sluggish before the turbo kicks in. Seems to be affecting all gears but no other symptons and no warning lights. Anyone any ideas? Cheers

  2. #2
    Regular Member mic's Avatar
    Join Date
    Jun 2007
    Location
    Lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine has also started doing exactly the same thing. Started yesterday and is even worse today, could the cause be the EGR valve?

  3. #3
    Admin & Membership Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    79 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    What rpm does your turbo kick in ?

  4. #4
    Regular Member big rich's Avatar
    Join Date
    Nov 2008
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra gsi

    Trim : Full heated leather

    Engine : 3200

    Year : 2004

    Default

    totaly the same as mine....before the turbo comes on boost it realy dosent pull at all......i will be keeping an eye on this thread

  5. #5
    Regular Member mic's Avatar
    Join Date
    Jun 2007
    Location
    Lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When I say mine doesn't pull you can put your foot to the floor in 1st gear and you could walk quicker until the turbo kicks in at about 2,000/2,500 rpm

  6. #6
    Regular Member
    Join Date
    Feb 2008
    Location
    Tarbert
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My turbo seems to kick in about 1900. Anything below this and it is just terrible...

  7. #7
    Moderator paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : M5

    Trim : Nothing needs adding

    Engine : 5.0 V10

    Year : 07

    Mileage : 37000

    Default

    Mine is in the garage for the same thing they thought it was the EGR but no fault codes at all so they reprogrammed the engine and gearbox ECU's then road tested it only to suffer a minor glitch they cannot explain it so they are keeping it for a few days and I will let you know what they find.

  8. #8
    Regular Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Is it the 120 or 150 bhp?

  9. #9
    Regular Member
    Join Date
    Feb 2008
    Location
    Tarbert
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry mine is the 150 on a 55 with 69k

  10. #10
    Moderator paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : M5

    Trim : Nothing needs adding

    Engine : 5.0 V10

    Year : 07

    Mileage : 37000

    Default

    150 with 43,000 and a six week old autobox and swirl valves all done under warranty luckily enough.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. lack of power
    By Alerxt in forum Engine & Drivetrain
    Replies: 8
    Last Post: 20th March 2011, 21:00
  2. Lack of power...
    By lightfx in forum Engine & Drivetrain
    Replies: 8
    Last Post: 20th October 2010, 14:33
  3. lack of power
    By dods in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 2nd July 2010, 20:33
  4. lack of power
    By astratovectra in forum Engine & Drivetrain
    Replies: 2
    Last Post: 20th February 2010, 19:56
  5. Lack of kick in 1.9cdti(150)2004
    By sanj in forum Engine & Drivetrain
    Replies: 2
    Last Post: 20th September 2006, 21:34

Visitors found this page by searching for:

vectra 1.9cdti lack of power

vectra c 1.9 cdti lack of power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •