User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: cleaned boost sensor and still shows over boost

  1. #1
    Regular Member
    Join Date
    Oct 2008
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default cleaned boost sensor and still shows over boost

    i cleaned boost sensor last night on the 2.2dci 52reg
    it was preety clean with no gunk at all?

    after cleaning i took a run and performance still slightly down and boosting when ever it feels

    diagnosis still comes up over boosting when light comes back on the dash

    only thing i noticed was a slight bubble on the yellow sensor element inside the boost sensor

    is there suppose to be a slight bubble ?

    the bubble is on the yellow element closest to the black flat thing in the middle

    i would buy a new one tomorrow if i wnew 100% it was this at fault but at £65.00 from local dealers it would be nice to know if there is anything else that could cause over boost before buying

    all pipes ok double checked

    cheers all

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    overboosting..

    dirty or damaged boost sensor
    stuck wastegate on turbo/faulty wastegate actuator
    split or perished vacumn lines leading to turbo.

  3. #3
    Regular Member
    Join Date
    Oct 2008
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    overboosting..

    dirty or damaged boost sensor
    stuck wastegate on turbo/faulty wastegate actuator
    split or perished vacumn lines leading to turbo.

    cheers again

    i think i know where the wastegate is>>> (behind turbo with a threaded bar and nut on it for adjustment)

    i will look at this to see if anything visual wrong with it

    if there is only the 3 things that could cause overboost then it might be worth just buying a new actuator and pipes and sensor

    cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. One cleaned Boost Sensor......
    By signum_1.9 in forum Engine & Drivetrain
    Replies: 20
    Last Post: 20th August 2012, 00:22
  2. Cleaned boost sensor
    By 130786howe in forum General Chat
    Replies: 0
    Last Post: 8th July 2012, 16:22
  3. please help, eml still onl, cleaned boost sensor and egr
    By J P S in forum Engine & Drivetrain
    Replies: 1
    Last Post: 31st May 2012, 12:25
  4. Just cleaned my boost sensor
    By bigdave1701 in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 30th July 2011, 19:43
  5. Just cleaned my egr and boost sensor !!
    By renton608 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 17th January 2011, 17:32

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •