User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Washer jets....

  1. #1
    Regular Member mc_orion's Avatar
    Join Date
    Aug 2007
    Location
    Worcester...and most motorways!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Washer jets....

    Mine seem to take ages to pump the liquid/water up to the screen for some reason....

    Ive only just noticed this, so anyome else have the same problem or is it just a quirk of the veccy's?

  2. #2
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Probably have a blocked pump,read about it on here a few time's,strip it out and clean pump,hose's and tank.........

  3. #3
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Should be fairly instantaneous mate....

  4. #4
    Regular Member Graham's Avatar
    Join Date
    Sep 2005
    Location
    Macclesfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Focus

    Trim : Titanium

    Engine : 1.6 TDCI

    Year : 62

    Mileage : 9K

    Default

    Yes mine instant too. As said, there are a few threads on here, the answer is strip bottle out and clean.

  5. #5
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Non return valve defective if you get a good jet of water eventually.

  6. #6
    Regular Member s0501291's Avatar
    Join Date
    Jun 2008
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had a similar problem. I changed the pump, cleaned out the mesh filter, and still no joy. Turned out to be a blockage in the T-piece of the jets. took both jets out, removed the pipe from each end of them and then pushed a small nale through to clear them. Works perfectly now. But on yours could be just the little mesh filter on the bottle, best to check the easy stuff first

  7. #7
    Regular Member
    Join Date
    Jan 2008
    Location
    Lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Hatch

    Trim : Exclusive Plus Pack

    Engine : 1.9 CDTi Z19DTH

    Year : 57

    Mileage : 100k+

    Default

    Agree with ste, if you're gettting good flow eventually. If the flow is poor then think blockage. With duff non-return valve (or a leak) fluid flows back down the tubes and it takes time to re-fill before it comes out of the jet. Had this in a previous car and fitted a new valve in the pipework.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Washer Jets
    By the-wizard in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 27th February 2010, 17:20
  2. washer jets
    By rickeys16v in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 22nd January 2010, 19:32
  3. Washer Jets
    By VikBee in forum Troubleshooting
    Replies: 3
    Last Post: 23rd December 2009, 09:06
  4. Are there any better washer jets out there..
    By bobby-tupper in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 11th December 2008, 20:45

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •