User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: loss of power

  1. #1
    Regular Member
    Join Date
    Oct 2008
    Location
    stoke on trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry loss of power

    Hello.
    I have a vectra c 1.9 150 CDTI
    Yesterday the spanner light came on and the engine would not rev above 2000 rpm. today the power is ok but the engine symble light is on all the time.does any one have a idear what the problem could be the car is 4 weeks out of warranty.
    cheers
    Keith

  2. #2
    Regular Member
    Join Date
    Oct 2008
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    its gone into limp mode mate
    i have same problem

    basically when your ecu realises there is a problem it tells your engine not to go above a sertain rev due to damaging engine

    usully a faulty sensor causes it

  3. #3
    Regular Member pricey's Avatar
    Join Date
    Dec 2006
    Location
    Dewsbury, West Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've had this happen twice on 1.9 cdti's and both times it has been the swirl valve that needed replacing. Take it to VX and get it
    diagnosed, with it been just out of warranty then they may stump up the full amount for the repair or in the worst case contribute
    a percentage towards it.

  4. #4
    Regular Member
    Join Date
    Oct 2008
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    also could be maff sensor

    i know it was a common problem on all older vectras and i have seen people with the c version have this too

  5. #5
    Regular Member
    Join Date
    Oct 2008
    Location
    stoke on trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks guys.booked in with vx tuesday.hope vx will help.

  6. #6
    Regular Member
    Join Date
    Oct 2008
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could be costly but has to be done

    i just orded a fault code reader for mine to cut future costs

    hope its something simple for ya mate

  7. #7
    Regular Member
    Join Date
    Oct 2008
    Location
    stoke on trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the fault code reader ?

  8. #8
    Regular Member
    Join Date
    Oct 2008
    Location
    stoke on trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    where could i purchase a code reader from.

  9. #9
    Regular Member
    Join Date
    Oct 2008
    Location
    chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by vectra kh View Post
    where could i purchase a code reader from.

    ebay this is the one i got but no guarentee it will work on every car

    http://cgi.ebay.co.uk/U581-08-Car-Di...1%7C240%3A1308

  10. #10
    Regular Member
    Join Date
    Oct 2008
    Location
    stoke on trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The problem has gone away for now and the lights gone off.
    car running ok.
    still kept the appointment with vx they say it is the swirl valve sticking in the inlet manifold.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. loss of power
    By STRETCH2009. in forum Engine & Drivetrain
    Replies: 6
    Last Post: 8th August 2012, 18:44
  3. Power loss HELP
    By dezzyb66 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 28th July 2012, 12:34
  4. 2L DTI '53 Loss of Power
    By BigTunz in forum Engine & Drivetrain
    Replies: 17
    Last Post: 3rd November 2011, 17:27
  5. loss of power
    By philly in forum Engine & Drivetrain
    Replies: 11
    Last Post: 11th May 2009, 07:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •