User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Thermostat 1.9CDTi

  1. #1
    Regular Member scoobs's Avatar
    Join Date
    Nov 2006
    Location
    Leicestershire in the sticks!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Thermostat 1.9CDTi

    Hi guys, been having probs with the temp gauge in my 04 SRi. No matter what the journey or driving style it takes 4-6 miles for the gauge to start moving and it never goes above 75 but the heating works fine. After reading previous threads I'm assuming the thermostat needs changing - is there anything model specific to the 1.9 150 and could anyone provides a muppets guide as I open the bonnet, and then I don't know my a**e from my elbow!!!
    Thanks in advance.

    ps - a pic of the thermostat location on a CDTi 150 would be a great help too.....lol

  2. #2
    Regular Member Stevie-B's Avatar
    Join Date
    Mar 2007
    Location
    NI
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    TBH mate if your not the most confident, I would find a good mech or an auto electrician that is clued up to sort this. The CTS (Coolant Temperature Sensor) units are also only worth getting brand new (at the stealers). No point sticking in a second hand unit. I would say for half the hassle getting it installed on your next major service would be money wise a better decision as well.

    Let us know how you get on....

  3. #3
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I wouldnt worry to much if I was you. My car takes ages for the temp gauge to register and if I have the heater on it usually sits below the 80 C mark. If I run with the heater off its runs about 85 C. By all accounts, I have heard people say similar with diesels. But a new thermostat may make it better.

  4. #4
    Regular Member solorider's Avatar
    Join Date
    Sep 2006
    Location
    swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : 1.9 120bhp

    Year : 2004

    Mileage : 139,600

    Default

    Quote Originally Posted by wickedwillie View Post
    I wouldnt worry to much if I was you. My car takes ages for the temp gauge to register and if I have the heater on it usually sits below the 80 C mark. If I run with the heater off its runs about 85 C. By all accounts, I have heard people say similar with diesels. But a new thermostat may make it better.
    my vectra cdti150 and my audi a4 tdi both take ages to warm up,more so on cold days,heater gives good heat after a short distance,i wouldnt worry about it as a lot of modern diesels do take a while to warm up and do run cold,my audi a4 had a new thermostat and still ran cool

  5. #5
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the car fully warmed up, put the heating on full blast, and driving round town the temperature gauge just dropped off the range...

  6. #6
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Penfold101 View Post
    I had the car fully warmed up, put the heating on full blast, and driving round town the temperature gauge just dropped off the range...
    Yep, last winter I noticed the same. If however you put the heater to setting 1 (slowest), I bet the temp gauge would register to near normal?

  7. #7
    Regular Member scoobs's Avatar
    Join Date
    Nov 2006
    Location
    Leicestershire in the sticks!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for all the advice and help fellas, after consideration i've decided ' If it ain't broke - don't fix it '. Not gonna worry about the gauge unless heater pack up or something.


  8. #8
    Regular Member andythilo's Avatar
    Join Date
    Oct 2006
    Location
    Saffron Walden
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Get the thermostat replaced, it's not letting the engine get up to temp.

    See here :

    http://forum.vectra-c.com/showthread.php?t=32456

  9. #9
    Regular Member scoobs's Avatar
    Join Date
    Nov 2006
    Location
    Leicestershire in the sticks!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It's actually booked for Tues, was gonna cancel but after reading your post and the related thread I'll let them do it.

    Thankyou.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9Cdti Thermostat removal
    By Cruize in forum Engine & Drivetrain
    Replies: 28
    Last Post: 24th December 2012, 16:15
  2. 1.9cdti 150 thermostat replacement
    By scotstrucker in forum Engine & Drivetrain
    Replies: 34
    Last Post: 5th June 2012, 20:01
  3. Thermostat change 1.9Cdti 120
    By alcutler in forum Engine & Drivetrain
    Replies: 8
    Last Post: 22nd January 2011, 16:00
  4. Thermostat for 1.9CDTI 150
    By GazVXLINE170 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 16th January 2011, 18:44

Visitors found this page by searching for:

vectra c thermostat 1.9 cdti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •