User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Strange and sluggish

  1. #1
    Regular Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Strange and sluggish

    Weird experience. Just nipped to supermarket. Fine run there. In for 10 mins then got back in car. Car started up well but felt like I was starting off in 3rd gear even though I was in first. This continued all the way home. Really sluggish starting off (almost as if starting in to high a gear). Even when revs up in 2nd, 3rd and 4th gear was sluggish and chuggy. Just about got home (5 min drive). Turned off. Left it for 3 mins and then started up again. Set off as norm. Had 10 min drive and felt a bit sluggish half way through, but not as bad as previous. Then again felt fine as if nothing had happened. Driving ok now. Anyone else had similar experience?

  2. #2
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What engine you got mate...?

  3. #3
    Regular Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry mate 54 1.9 cdti

  4. #4
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok, if it's gone it may have jsut been a blip, if it comes back see if it puts on a management light on the dash, and get the dealer to read it. It'll give you aa route to look at as to what might be wrong...

  5. #5
    Regular Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That's the thing, no light came on (although I was waiting for it). Hopefully just a blip! Don't fancy stealers, particularly when I'm not sure what it is.

    Thanks mate.

  6. #6
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Bit of air in the fuel maybe or something odd in the fuel... Anything wrong with the engine itself would've thrown up a light I think...

    Anyone else with some thoughts...?

  7. #7
    Regular Member joules2.0t's Avatar
    Join Date
    Aug 2005
    Location
    surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : SRI


    Year : 53

    Default

    Might be worth putting some injector cleaner in....

    Similar problems on petrol engines is normally caused by the EGR valve being full of gunk - hesitates etc.... Not sure about Diesel

  8. #8
    Regular Member
    Join Date
    Jan 2007
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Low engine power.

    Sorry to bring bad news, but....... Hopefully it's just a blip, but mine's the same model and it certainly wasn't! First time, at 34,000, it was the egr valve. Cost me over £200 altogether. Now at 40,000 it's in dock again. Same symptoms, but this time, the egr valve has gone again and the dreaded swirl valve too. They're doing the egr under warranty, but the new manifold / swirl set up is going to cost me a fortune. (Over £700!) Now shall I reconsider that Insignia? Wonder what they'll leave the customers to find wrong with that?

  9. #9
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like jammed swirl valves to me. As Kenny says, it'll be expensive.

  10. #10
    Regular Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the feedback. Been out today a couple of times and no problem at all. Kenny how intermittant was yours when you had the problem or was it constant?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 SRi Sluggish
    By obews in forum Engine & Drivetrain
    Replies: 15
    Last Post: 2nd November 2012, 20:30
  2. sluggish
    By iokarus in forum Engine & Drivetrain
    Replies: 8
    Last Post: 29th February 2012, 20:35
  3. Sluggish again
    By durham4416 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 7th February 2011, 18:20
  4. sluggish
    By chrosty in forum Diesel Engine related
    Replies: 13
    Last Post: 29th December 2010, 23:55
  5. sluggish 1.9 cdt
    By thommo in forum Introduce yourself.
    Replies: 3
    Last Post: 16th March 2010, 14:57

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •