User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Cruise Control problem, HELP pls

  1. #1
    Regular Member
    Join Date
    Apr 2008
    Location
    west mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Cruise Control problem, HELP pls

    Hi there,

    My cruise control lately has a mind of its own

    It sometimes works ie light shows on dash and sometimes it just point blank refuses to engage

    Didnt work one day and then it did in the night and then next day didnt work again!

    Is there something i need to do?

  2. #2
    Regular Member s0501291's Avatar
    Join Date
    Jun 2008
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same problem on mine,, Somthing that you can try is pulling the clutch pedal up with your foot when your driving. Their is a switch on the clutch pedal that dis-engauges the cruise control when you press the clutch. Somtimes the spring which is supposed to return the pedal to the fully up position when your foot is off the clutch can break or be strained. If you find that the cruise control works when you pull the clutch up fully then you probably need an new pedal spring, OR you could do some DIY on the switch by gluing in somthing that will take up the slack.

    Hope this helps

  3. #3
    Regular Member Morephun's Avatar
    Join Date
    Mar 2008
    Location
    everywhere
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vec c

    Trim : sri

    Engine : 150 cdti

    Year : 55

    Mileage : 108000

    Default

    yup mine was the same till i got a spring for the rear of it..

  4. #4
    Regular Member gogs37's Avatar
    Join Date
    Jul 2008
    Location
    inverallochy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    im having the same problem but it always fixes itself when i restart the car

  5. #5
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Faulty stalk?

  6. #6
    Regular Member mark1319's Avatar
    Join Date
    Apr 2007
    Location
    Tyneside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You have to press the brake as well, found this out when I came out of services and it wouldn't work because I hadn't pressed the brake.

  7. #7
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Mine used to malfunction, was dirty contacts on the stalk. A bit of contact cleaner and a few good presses and it's been OK since.

    Not sure about the having to have actuated the brake pedal once before it will engage. I read it before on here and understand the reasons for it (to ensure brake actuation will disable CC and not get the engine powering against braking when you press the brake, as you may need to stop quickly, and don't want extra braking distance from the engine straining too)

  8. #8
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It clearly states in the manual that you need to depress the brake once before the CC works. I believe it's to ensure the brake switch is working, so you don't end up with the CC fighting the brakes in an emergency.

  9. #9
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    My car definitely does NOT need the foot brake to have been operated before CC will engage.

    I tried it last night when i filled up with petrol, and this morning when I went to work.

  10. #10
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Then your car is faulty...

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. different cruise control problem
    By greenmeanie in forum Engine & Drivetrain
    Replies: 12
    Last Post: 2nd December 2015, 19:42
  2. cruise control problem
    By Bigtee in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 21st March 2012, 22:07
  3. Cruise Control Problem
    By gsi.vxr in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 1st May 2010, 13:16
  4. cruise control problem
    By Lee.. in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 2nd March 2009, 21:37
  5. cruise control problem
    By Herman in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 12th December 2008, 19:10

Visitors found this page by searching for:

https:www.vectra-c.comforumshowthread.php60386-Cruise-Control-problem-HELP-pls

vectra c cruise control problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •