User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: 2.2SRI petrol accelered on its own!!!!!!!

  1. #1
    New Member
    Join Date
    Jul 2008
    Location
    Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2SRI petrol accelered on its own!!!!!!!

    A month back I'm driving to work, just after a corner I notice my car suddenly starts accelerating away without me pressing on the accelerator? The yellow engine management light comes on. I knock it out of gear and the revs fly up. I put it back in gear to drive to a safe place to stop using my brake to control my speed.

    When I stopped I quickly turned the engine off as it was reving the ar*e of it and contemplated on some possible consequences if it had happened in busy area!

    After a minute or two I plucked up the courage to start the engine again.............it was back to normal? and the engine management light had gone out????? I thought it was supposed to stay on until reset?

    No faults found at the local garage although he did give me the last fault code(have it wrote down at home will type in when i get back home in the morning)
    I can just remember it was something to do with the air to the engine??

    Anyway I get in the car tonight turn the key and oh no not again... high revs+ engine management. After turning the engine on/off after 3 attempts the revs are back to normal, this time the engine management light is still on.

    Any ideas before I take it to the garage? Anyone else had a similar problem?

    Cheers for any replies.

    2.2 SRI pertrol
    2003 pre-facelift (not direct)

  2. #2
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Check for air leaks mate. Get the TB off first and look at the rubber gasket and check its all fine. Then go round the Manifold and check all the vac hoses are plugged in fine, its highly unlikely that the manifold is cracked but you might as well check it out while your there. The only places for air to get in are from the TB back though the manifold to the head. Check the butterfly in the TB moves nice and freely. If you have a helper you can check the TB, it has a self test. Take the air intake off and get someone to look at it while you switch on the ignition, the butterfly should so a self test by opening and shutting. If after all this you still get the problem then you getting into electrical gremlins and thats something that someone with far more knowledge will have to help you with. HTH

  3. #3
    New Member
    Join Date
    Jul 2008
    Location
    Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the reply Rushy I'll try that later when I get up, going to bed now just come off nights.

    I've found the fault code from last time it happend its P0108 and he said it was mass or volume air flow circuit.

    Don't want to take it to a main dealer due to high costs but i wonder if its worth me getting in touch with them as this could clearly be a safety issue? they maybe interested.

  4. #4
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    The way the engine works is it measures the air coming in then adds fuel accordingly. It could be your MAF, I presume you know but its the block just after the air filter. Next time it does it, try unplugging it, you will get an EML but the car should still drive on base info. You dont use a K&N do you? The oils you spray on them can affect the MAF's and cause then to give a false reading.

  5. #5
    New Member
    Join Date
    Jul 2008
    Location
    Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have poor knowledge of my car innerds, i tend to find out about things when they go wrong. My car has no mods just box standard.

    When i started my car up tonight my engine management light has gone back out again with out me doing anything

    After i finish this block of night shifts I'll pop the bonnet and do the checks you suggested in your first post and I will hunt out the MAF so I'm ready for unplugging if.... no.......when it happens again.

    Cheers

  6. #6
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Its not good to unplug the maf mate but it may help to narrow your problem down. If you know someone with a 2.2 vec C you could always borrow there's for a trial run. The 2.2 in the Astra and vec b is exactly the same lump as yours but they run a MAP not a MAF so using one from them will not work.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005, 2.2sri
    By stuk2000 in forum Cars for sale
    Replies: 1
    Last Post: 29th November 2009, 11:57
  2. Mpg On 2.2sri Petrol
    By mondeoman in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 14th September 2008, 15:36
  3. 2007 2.2SRI with XP kit
    By rob888 in forum Cars for sale
    Replies: 5
    Last Post: 30th December 2007, 20:14
  4. Cyb 2.2Sri
    By cyb in forum Quick Photo Album
    Replies: 18
    Last Post: 1st July 2005, 09:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •