User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: CD 70 NAVI cd not ejecting

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    Lancs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CD 70 NAVI cd not ejecting

    Hi Guy's, you wonderful lot out there,
    now the grovelling is done, I have a CD 70 NAVI in my car, with the CD stuck inside. When the eject button is pressed, it sounds as though it is attempting to eject, but doesn't. Does this have a manual eject mechanism anywhere, or can it be released by removing the unit.

    Thanks in advance for any info or help

    Regards

    Neil

  2. #2
    Regular Member
    Join Date
    Jan 2006
    Location
    Hornchurch
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    give it a Hit just a light tap

  3. #3
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had this and I drove the car with the heater on full heat for about 20 mins to get the interior roasting then it ejected. Thermal expansion of different parts. Justa suggestion

  4. #4
    Regular Member
    Join Date
    Aug 2008
    Location
    Lancs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just tried that (tapping it), but did not work on this problem, thanks anyway for that tip

  5. #5
    Regular Member sig63's Avatar
    Join Date
    Aug 2006
    Location
    Belgium
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Insignia

    Trim : Cosmo

    Engine : 2.0 CDTI

    Year : 2011

    Default

    try gently inserting another disc while pushing on the eject button

  6. #6
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Before you do this, make sure you have the passcard or know the code number
    Usual solution is to remove the fuse, wait 10 minutes
    Reinsert fuse
    The CD should eject
    If not, then the unit will have to be removed

  7. #7
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Heat the front of it up gently with a hairdryer. Not to hot but its may just do the trick

  8. #8
    Regular Member LJ sxi-nav's Avatar
    Join Date
    Apr 2007
    Location
    Winchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sig63 View Post
    try gently inserting another disc while pushing on the eject button
    What sig63 said - I had an audio CD stuck in my cd70. Unit behaved like there was a CD inserted (it would play) but didn't KNOW it was inserted! Pushing another CD in (use and old CDR and do it carefully LOL) fooled the mechanism that a CD was now in and it ejected the one that was stuck.

    Other people with different units have suggested putting 2 cd's in the slot and trying to sandwich the stuck cd to then pull it out - i couldn't get this method to work on CD70 though.
    Last edited by LJ sxi-nav; 17th August 2008 at 12:14.

  9. #9
    Regular Member
    Join Date
    Aug 2008
    Location
    Lancs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My appologies for not getting back earlier, but I have eventually tried a few more tips, but with no success. But have since looked inside the unit though the slot with a torch. And, could not see any signs of a CD. I have also removed the head unit, and removed the CD unit from this. Inside was found a couple of coins, and a guide wheel was also moving around freely. I have put it back together, and tried again, but it appears the debris in there has done its damage, as one of the cogs for ejecting has worn its teeth away.
    Does anyone know where to get hold of a replacement cd unit, or if these cogs are replaceable (maybe at a cd repair place).
    The unit is a CDM M6 4.7/84 SO 736 9307 005 60436

    Thanks again for all the tips recieved earlier

    Neil

  10. #10
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what you need to do is not 'just buy one' on ebay... the unit needs 'un pairing' from the donor car before it can be 'paired' to yours...

    i think it'll either be a case of buying a broken unit to rob for parts, or the expensive route of using VX's own repairers..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CD Player Error (not playing or ejecting)
    By SW-ZC in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 9th May 2012, 10:35
  2. Signum in dash autochanger not ejecting?
    By pgilc1 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 8th November 2009, 20:22
  3. CD 70 Navi
    By simsr4 in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 5th January 2009, 22:55
  4. NCDC 2013 keeps ejecting the Nav CD
    By David_SRi_2.2DTi in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 5th August 2007, 20:06

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •