User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Emissons light

  1. #1
    Full Member tubby's Avatar
    Join Date
    May 2007
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra sri


    Engine : 2.2 z22se

    Year : 2003

    Default Emissons light

    Hi ive just had a week away,got back yesterday got in my car this morning drove around for a while and the emissons light came on.the car seems to be running fine, is it bcos it hasnt been driven for a week or something major any ideas?oh the car is a 2.2 petrol 53reg thanks

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it could be a few things, but it's best to get it checked before any possible overfuelling kills the catalyser

  3. #3
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Some over fuelling won't kill the cat, BUT do get it checked out as soon as. It's just as likely to be under fuelling as over fuelling though.

    With the lamp being on, there will be a code stored that will hopefully diagnose the problem. Unless the emissions light flashes then you can still use the car a bit.

  4. #4
    Full Member tubby's Avatar
    Join Date
    May 2007
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra sri


    Engine : 2.2 z22se

    Year : 2003

    Default

    Well its all sorted fingers crossed,spent half an hour looking through the forum and found a thread saying disconnect battery for a while and reconnect it done that and all ok!!

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    That will just clear the stored code not fix the problem mate.

  6. #6
    Regular Member Vid's Avatar
    Join Date
    May 2007
    Location
    In the inventing shed...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This happened to mine mate, just wait and see if it comes back on in 4-5 days. Turned out to be the lambda, despite the code given showing coil pack or spark plug fault, so replaced those first, hopefully the new lambda cures it!

  7. #7
    Full Member tubby's Avatar
    Join Date
    May 2007
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra sri


    Engine : 2.2 z22se

    Year : 2003

    Default

    il have to get it looked at then,have you had this problem with having the same engine rushy?

  8. #8
    Full Member tubby's Avatar
    Join Date
    May 2007
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra sri


    Engine : 2.2 z22se

    Year : 2003

    Default

    how much did that set u back vid with out me being rude?

  9. #9
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by tubby View Post
    il have to get it looked at then,have you had this problem with having the same engine rushy?
    No mate, mines running sweet as a nut at the moment.

  10. #10
    Full Member tubby's Avatar
    Join Date
    May 2007
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra sri


    Engine : 2.2 z22se

    Year : 2003

    Default

    alright for some!!

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 4
    Last Post: 18th August 2012, 08:58
  3. Replies: 17
    Last Post: 16th August 2012, 10:07
  4. Clearing Emissons light
    By ianh in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 6th July 2011, 21:23
  5. PLEEEEASE HELP - traction control light/power steering light on!!!
    By holdenvectra in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 28th June 2010, 23:39

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •