User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Wtf! Passenger Wiper Packed Up.

  1. #1
    Regular Member kev bux's Avatar
    Join Date
    Jan 2006
    Location
    BOROUGHPETER
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Wtf! Passenger Wiper Packed Up.

    Well i was on my way to my parents this morning and it absolutly ****ed it down with rain, wipers were on for about 15mins and then suddenly the passenger side wiper stopped working. thank god it wasn't drivers side, .

    anyway when i got to my parents i had a look and this is what i found,



    the wiper arm had come out of its socket were it is attached to the drivers wiper arm, i re-attached it but it didn't last no more than a minute before it came off again so pic below shows what i have done for now(cable tied together, works fine like this but dont know how long for).



    anyone else had this happen, if so what did you have to buy/how much to get it sorted.

    cheers

    kev bux.

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep, it's a common problem - many a thread on it.

    There's now a modified wiper linkage (better design) that Vx sell. It's around £70 and doesn't take too long to fit.

  3. #3
    Regular Member kev bux's Avatar
    Join Date
    Jan 2006
    Location
    BOROUGHPETER
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Duncan View Post
    Yep, it's a common problem - many a thread on it.

    There's now a modified wiper linkage (better design) that Vx sell. It's around £70 and doesn't take too long to fit.
    how much!

    surely vx should be doing them for free if they are a common fault, if they made a better design why not recall them back to be changed?

    i will stick with the cable tie for now and carry a few spares with me.

  4. #4
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    P.S. Don't let your dealer tell you that you also need to buy a new motor as well with the reason that the linkage won't fit to the existing motor - quite a few people have been told this and it's cobblers.

    I think it's down to the entry in EPC. On the new linkage entry it says to supply with a couple of other part numbers, one being the new motor, so they take that as meaning that you have to have the new motor. You don't - the new linkage fits just fine onto the existing motor and the linkage kit has all the bolts etc. that you'll need.

  5. #5
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep, it's a fair few quid for what is effectively a design fault, but Vx, or any other manufacturer, wouldn't issue a recall for that sort of thing.

  6. #6
    Regular Member
    Join Date
    Feb 2007
    Location
    Leicestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Same thing happened on Tuesday to my 54 reg Signum at 75+mph whilst overtaking in the pouring rain. Wipers going flat out at the time. Very frightning experiance. Called into main stealer who quoted £74 for the linkage, and how many did I want. "got plenty in stock, common fault on Vectra and Signum." I told him where to stick it.
    Anyway after a couple of hours in the garage I have fully rebuilt the linkage with eye ends from a pnumatic cylinder and some lenghths of 10mm screwed rod, various nuts and bolts. (Vauxhall might take notice of the design) It works a treat, and if any of the joints fail again can be replaced individually for £5.00 each. Total price for parts under £30.00. Still cheaper than a second had unit and probably more reliable. I will try to upload photos if antone is interested.

    Pete

  7. #7
    New Member
    Join Date
    Jan 2010
    Location
    dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have just experienced the same problem with my 04 signum.
    not much of a mechanic , but was wondering how simple this fix is ?
    anyone got an idiots guide for an idiot !

  8. #8
    Regular Member vectrasri-j's Avatar
    Join Date
    Sep 2009
    Location
    luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTI 120

    Year : 2006

    Mileage : 100000

    Default

    i had this same problem yesterday, done exactly what you did popped it back into the socket and cable tied it, makes a clunk noise when it goes up but still works and does the job

  9. #9
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    There is loads about it on here. Look here for discussion and a link to a how to fix. I would read all the comments too.

    http://www.vectra-c.com/forum/showth...ighlight=wiper

    Replacement may be the only long term solution.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Passenger side wiper has given up
    By GoblinKing in forum Bodywork & Interior
    Replies: 10
    Last Post: 30th April 2011, 14:52
  2. passenger wiper faulty
    By IA76 in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 8th December 2009, 13:49
  3. memory seats packed in,auto wiper/light not working etc etc
    By uaintsinme..right in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 30th August 2009, 18:24
  4. Passenger wiper DEAD!
    By caravaner-tony in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 2nd February 2009, 23:22
  5. help - 1 wiper packed in
    By Graeme in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 11th April 2008, 10:16

Visitors found this page by searching for:

vectra c 2006 passenger wiper not working

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •