User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: massivly erratic 3.0l

  1. #1
    Regular Member
    Join Date
    Jun 2007
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default massivly erratic 3.0l

    Original thread here:

    http://forum.vectra-c.com/showthread.php?t=52875

    The problem cleared up for a couple of weeks but is now back with a vengeance!

    Acceleration at any point, not just flat out, can either be perfect, or it has massive flat spots and huge juddering fits through the range 0-70mph!! Both of which is just seems to 'get over' in its own time and give me the whack of acceleration I expect!

    It also seems to at random points jump up and down in the revs 2500 to 1500 then back, then back, then back then accelerate

    Problem *seems* much more pronounced up hill

    This has happened pulling out of junctions etc so is just stupidly dangerous!

    It is booked into the stealers for Thurs but it may have cleared up by then.... any advice?

    I had the missus record the clocks while I put my foot to the floor, can link people to the video if anyone can possibly help diagnose?

  2. #2
    Regular Member vectravirg's Avatar
    Join Date
    Sep 2006
    Location
    Bolton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Had problems with my 3.0 going into limp mode at random times if I put my foot down, sounds like different symptoms to your's but mine a replacement MAF sorted mine out.

  3. #3
    Regular Member
    Join Date
    Jun 2007
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yeah the weird thing is it isn't going into limp or kicking out any dashboard lights!

    I can almost guarantee it will be fine when the garage get it which is the frustrating thing!

  4. #4
    Regular Member vectravirg's Avatar
    Join Date
    Sep 2006
    Location
    Bolton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Same thing with mine going in limp mode all the time, take it to the dealers no problem at all. Replaced the boost pressure sensor, fuel rail, manifold and eventually the MAF, so take your pick from any of them!

  5. #5
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Presumably a 3.0 V6 CDTI
    Mine used to do this as well
    People were suggesting all kinds of things, from clutch slip to MAF, and so on
    However, my local VX dealership finally managed to trace it to the traction control

    Does it sound like this...

    Pottering a long at a set speed, say 50mph, in a high gear, say 5th
    Want to overtake so come down a gear or two
    Foot to the floor, the revs increase but the speed stays the same
    Then the revs come back down to what they were, then the speed and revs perform as you expect

  6. #6
    Regular Member
    Join Date
    Jun 2007
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No the revs rarely move, it sticks totally at a set mph and set rev's the gives a whack of power

    Occasionally the revs flick up and down a bit but mostly it just sticks!

  7. #7
    Regular Member
    Join Date
    Jun 2007
    Location
    Devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Fuel pressure valve apparently

    6hrs work and £600 they think, just checking if its covered under my 3rd party warranty

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Erratic A/C Can someone shed some light
    By looloo2 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 26th May 2012, 10:09
  2. Erratic Revs
    By kel123 in forum Engine & Drivetrain
    Replies: 42
    Last Post: 22nd August 2011, 16:08
  3. V6CDTi - Erratic idling
    By Celes in forum Engine & Drivetrain
    Replies: 2
    Last Post: 5th January 2011, 20:21
  4. 3.2 erratic idle
    By Annalogg in forum Engine & Drivetrain
    Replies: 3
    Last Post: 25th June 2010, 13:26
  5. Erratic CANBUS
    By johnmac in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 28th May 2009, 22:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •