User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Vectra 1.8 poor performance

  1. #1
    Regular Member
    Join Date
    Jul 2008
    Location
    SAUCHIE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra 1.8 poor performance

    Hi all.

    I have a 1.8 vectra on an 05 plate and it has always had a bad flat spot at low revs usually when pulling away from roundabouts and junctions. Had the car into vauxhall as many times and there guys can't find a problem so managed to live with it for years but now it has an even worse problem where as I am slowing down to roundabouts with foot off throttle its like someone blips the throttle causing the car to lunge forward. I have even bought the OP-COM software and put my laptop on it which shows now faults. The flat spot isn't present when I drive the car at night. The lunge problem is there constantly. HELP ????

  2. #2
    Regular Member JonV6's Avatar
    Join Date
    Mar 2008
    Location
    Cardiff
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I can sympathise scots, had a Corsa SRi 1.8 which used to lunge off the gas....

    Never really found out why. I was never happy with the fly by wire throttle on the 1.8, slow to respond, flat and lurchy!....

    Suprisingly enough, things did improve however after fitting a K&N and doing the airbox mod...

    You say the flat spot isn't there at night, anything to do with air temp I wonder, probably unlikely on a NA engine.....

  3. #3
    Regular Member Leviathan's Avatar
    Join Date
    Feb 2008
    Location
    Middlesbrough, Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by JonV6 View Post

    Suprisingly enough, things did improve however after fitting a K&N and doing the airbox mod...

    You say the flat spot isn't there at night, anything to do with air temp I wonder, probably unlikely on a NA engine.....
    Not a bad theory!

  4. #4
    Regular Member
    Join Date
    Jul 2008
    Location
    SAUCHIE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers. what is this mod and where and how do i get it. The throttle peddle and throttle body all show as working correctly on the laptop. The peddle is opening to 100% and body also.

  5. #5
    Regular Member sduk's Avatar
    Join Date
    Jul 2008
    Location
    Dundee, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i hada similar problem on my MG ZR, I replaced the HT leads and this stopped it, not sure if it would be the same for the vectra?

    hope you get it sorted mate

  6. #6
    Regular Member Leviathan's Avatar
    Join Date
    Feb 2008
    Location
    Middlesbrough, Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Made a big difference to mine, 2.0dti:

    http://forum.vectra-c.com/showthread.php?t=15122

  7. #7
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Airbox mod would solve this issue,have done it my 1.8,here you go.........

    http://www.vectra-c.com/forum/showthread.php?t=1186

  8. #8
    Regular Member sduk's Avatar
    Join Date
    Jul 2008
    Location
    Dundee, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Leviathan View Post
    Made a big difference to mine, 2.0dti:

    http://forum.vectra-c.com/showthread.php?t=15122
    great thread! I have bought the k&n panel filter but was not aware of the air box mod! will defo have to try that! also have bought the VXR cold air intake.

    wonder if those three will make much difference?

  9. #9
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have done the mod and the GSI air intake,so much better now,no flatspot and a has a bit of a grunt now............

  10. #10
    Regular Member
    Join Date
    Jul 2008
    Location
    SAUCHIE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    just by cutting out this peice of pipe will help the flat spot or the lunge proplem??

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Very poor performance 1.9 cdti
    By uk300bake in forum Engine & Drivetrain
    Replies: 14
    Last Post: 8th August 2012, 16:08
  2. poor performance
    By dirtball-tony in forum Engine & Drivetrain
    Replies: 1
    Last Post: 5th October 2011, 09:16
  3. Need help, veccy 1.6 poor performance..
    By bedo13 in forum Engine & Drivetrain
    Replies: 18
    Last Post: 2nd April 2011, 20:13
  4. 3.0V6cdti Poor Performance
    By Les Scott in forum Engine & Drivetrain
    Replies: 13
    Last Post: 30th November 2008, 15:56
  5. very bad shuddering poor performance.
    By jaff in forum Engine & Drivetrain
    Replies: 7
    Last Post: 13th August 2008, 20:06

Visitors found this page by searching for:

vauxhall vectra lunges off throttle

fly by wire flat spots vectra

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •