User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Query - Diesel Filter / Electrics / Transmission Light

  1. #1
    Regular Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Query - Diesel Filter / Electrics / Transmission Light

    Had the car serviced Tuesday at a Nationwide Autocentre. When picked up I had strong smell of diesel coming into cab through vent when heater was on. Took back and they said they found a problem with the connetion to the diesel filter which meant diesel has leaked onto starter motor. This is now fixed. However, now when I put key in ignition the 'car and spanner' light illuminates and stays on until I start the engine at which point it turns off. I went back in and told the manager but he said this was usual and there is only a problem if the light comes on when the engine is running. However, I'm pretty sure that it didn't use to come on before the service. Any suggestions would be welcome?

  2. #2
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    259 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    Means it had detected a fault and is no longer present.. Dunno if its related to your previous problem though.. Should clear itself from the ECU memory after about 25 clean engine restarts

  3. #3
    Regular Member
    Join Date
    Jun 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Many thanks. He said it could be that they had to disconnect a part to rectify the problem and clean the excess diesel from around the starter motor. Could this have caused the fault it picked up and so now is rectified as it was replaced?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slight diesel leak from Diesel filter housing :-(
    By rollercoaster63 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd July 2015, 21:18
  2. Location of Automatic Transmission Filter
    By der_stig in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 19th July 2012, 17:55
  3. Engine Fault Light - Water in Diesel Fuel Filter?
    By rharris21 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 14th February 2012, 10:06
  4. water in diesel filter, spanner light and fault code
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 21st October 2011, 19:24
  5. Diesel Particulate Filter Query / Clarification
    By dave45040 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 27th January 2007, 21:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •