User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: strange noise when turbo is on boost

  1. #1
    Regular Member
    Join Date
    Nov 2007
    Location
    Chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default strange noise when turbo is on boost

    hiya guys , i have a 52 plate vectra 2.0 DTi , and when the turbo starts to boost i can hear a noise from under the bonnet on the offside wich sounds like a window is slightly down ( thats posssibly the best description i can give ) other than that the car runs fine. i had a look under the bonnet, couldent find anything untoward also the radio/cd player will only work off the controls on the steering wheel any ideas / solutions ? many thanks dave mac

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Has it always done this? It might be the turbo whistle you can hear, or possibly a split in one of the boost hoses. HTH
    Now I need a turbo to keep up!

  3. #3
    Regular Member
    Join Date
    Nov 2007
    Location
    Chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default strange noise when turbo is on boost

    hiya Big Sig, the noise i described started yesterday, in the past you can hear the turbo whistle as it comes on boost. this noise is different i will have a closer look at the hoses , many thanks for the reply . dave mac

  4. #4
    Regular Member addyboy1982's Avatar
    Join Date
    Dec 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Sig View Post
    Has it always done this? It might be the turbo whistle you can hear, or possibly a split in one of the boost hoses. HTH

  5. #5
    Regular Member Stu14t's Avatar
    Join Date
    Jan 2007
    Location
    Perth, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had an the same problem with another turbo diesel I had. What happened was the pipe from the turbo (boosted side don't know if it goes to the intercooler or on to the inlet manifold) was not connected back correctly and under no load there was no noise. However, when on boost there was a definite whistle, or even whoosh at times as the preasure forced it's way out.

    If it's a split hose could be difficult to trace as it only happens under load.

  6. #6
    Regular Member Karl's Avatar
    Join Date
    Apr 2007
    Location
    Sunderland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    my old DTi split the hose (kinda spider cracks) and it started doing the same, a new hose and it was all ok

  7. #7
    Regular Member
    Join Date
    Nov 2007
    Location
    Chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i took the black plastic cover off the top of the engine and found a split in the hose i have done a repair on said hose and all is well. ( will get a new hose tomorrow from the squealers ) thanks for the info guys . dave mac

  8. #8
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Here to help mate
    Now I need a turbo to keep up!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. car running lumpy and now strange wooo sound when coming of boost??
    By richiem in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 4th June 2012, 13:00
  2. Strange power boost
    By signum_rob in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 16th January 2012, 00:05
  3. Strange Noise From Turbo
    By Brooky18 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 20th November 2009, 20:19
  4. strange turbo noise
    By twaiter in forum Engine & Drivetrain
    Replies: 18
    Last Post: 17th November 2009, 13:47
  5. Strange noise on kickdown - turbo or Auto?
    By NPS in forum Engine & Drivetrain
    Replies: 5
    Last Post: 14th August 2008, 12:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •