User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: I've got a question about an Omega...

  1. #1
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : very

    Engine : Z19DTH

    Year : Nosey

    Default I've got a question about an Omega...

    I have a friend who is having some trouble with a 3.2 Omega and I'm sure some of you older one must have had an Omega in your times. It is missfiring when cold and pulling up a lamba sensor fault. Anyone got any ideas or past experiance?

    I have read around and some suggested changing the engine temp sensor and and other say clean the CATs with cataclean.

  2. #2
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    On a funny note, when you hold the cursor over this post on the main listing screen, it previews the first few lines of it. In this case, it ended with:

    I have read around and some suggested changing the engine...
    Seems a bit overkill to me....

  3. #3
    Regular Member
    Join Date
    Jun 2008
    Location
    South east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sign up to www.OmegaOwners.com and post details of your issue there....it's a very technically-minded forum, they'll give you some answers (altho I can guarantee they'll start with "what error codes are showing" lol).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my omega,
    By taylor in forum Non Vectra C/Signum Album
    Replies: 9
    Last Post: 21st April 2010, 15:05
  2. omega question
    By wardy in forum General Chat
    Replies: 3
    Last Post: 29th November 2009, 21:33
  3. Omega 3
    By WeDesign in forum General Chat
    Replies: 11
    Last Post: 10th February 2009, 11:42
  4. omega
    By 06 vectra in forum Cars for sale
    Replies: 0
    Last Post: 9th September 2008, 18:28
  5. The new omega?
    By lborob17 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 2nd November 2006, 11:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •