User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: emission light and fuel trim bank 1

  1. #1
    Regular Member pipamish's Avatar
    Join Date
    Mar 2006
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2005

    Default emission light and fuel trim bank 1

    ive had this problem for a while now my emission light comes on and goes off all the time i had the rac look at it and they gave me 2 error codes they were po100 and po170 these are mass air flow and fuel trim bank 1 i know it is running rich but the problem im getting is starting it up every morning the choke will kick in and when the revs start to drop it really trys to cut out then all of a sudden the revs will shoot back up when i try to drive pulling off in low revs it will try to cut out when i put pedal to the carpet it slowly picks up but there is a little pop sound from the front also the car seems very sluggish i know this isnt healthy. i did take it to the dealers and they said there were 2 fault codes but they wasnt present so they didnt want to carry on withj any work i was told to just bare with it. at pvs dean plasma put it on his nice bit of kit and the same codes popped up but 1 was present it was the fuel running lean but the airflow seemed quite low do you think if i changed the oxygen sensor on the air intake this would improve please advice needed

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it's not the oxygen sensor on the air intake.. you're a bit misdirected there...

    the MAF sensor has not a lot to do with it.. it's the lambda sensor saying it's getting out of range values, so is flagging a code...

    i'd swap the lambda

  3. #3
    Regular Member pipamish's Avatar
    Join Date
    Mar 2006
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2005

    Default

    Quote Originally Posted by Gsi3.2 View Post
    it's not the oxygen sensor on the air intake.. you're a bit misdirected there...

    the MAF sensor has not a lot to do with it.. it's the lambda sensor saying it's getting out of range values, so is flagging a code...

    i'd swap the lambda
    cheers where would i find this sensor

  4. #4
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    in the exhaust manifold.. which engine size is it you have again??

  5. #5
    Regular Member pipamish's Avatar
    Join Date
    Mar 2006
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2005

    Default

    Quote Originally Posted by Gsi3.2 View Post
    in the exhaust manifold.. which engine size is it you have again??
    i have the 1.8 is it easy to remove some garage told me you have to crack it off and sometimes it doesnt come off probably and then you have to replace the manifold

  6. #6
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it does need removing carefully...you'll need to use plenty of WD40 before and let it soak in, and use a proper socket to remove it..

  7. #7
    Regular Member pipamish's Avatar
    Join Date
    Mar 2006
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : 2.0 turbo

    Year : 2005

    Default

    Quote Originally Posted by Gsi3.2 View Post
    it does need removing carefully...you'll need to use plenty of WD40 before and let it soak in, and use a proper socket to remove it..
    do you think im best off buying this sensor and paying a garage to do it for me

  8. #8
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    in case it goes wrong and you don't feel confident you have the facilities or ability to remove it, then yes it could be a good idea...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fuel trim bank 1 & 2 and misfire due to low fuel
    By shaunft in forum Engine & Drivetrain
    Replies: 7
    Last Post: 30th August 2012, 15:40
  2. spanner light reset emission light now on HELP!
    By johnny boy67 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 7th December 2009, 12:07
  3. Emission light on.
    By ExclusivDoug in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 1st April 2009, 10:36
  4. emission light help!
    By platty in forum Engine & Drivetrain
    Replies: 13
    Last Post: 22nd August 2008, 18:09
  5. help! fuel bank 1 code
    By nicoleb in forum Engine & Drivetrain
    Replies: 6
    Last Post: 17th April 2008, 12:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •