User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: 2.2dti elegance

  1. #1
    New Member
    Join Date
    May 2008
    Location
    redditch
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2dti elegance

    Hi, all, I have just bought a 2.2 dti elegance, beautifull car, but was driving it yesterday on dual carriageway at bout 70-75mph when car with spanner light came on and cars pickup dropped, parked it up switched it off then on again and it was fine, what could problem be?, also I think fuel consumption is a bit high, does 350-400 miles to full tank is that normal or high, also how to improve fuel economy. Thanks.

  2. #2
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by vectra taxi View Post
    Hi, all, I have just bought a 2.2 dti elegance, beautifull car, but was driving it yesterday on dual carriageway at bout 70-75mph when car with spanner light came on and cars pickup dropped, parked it up switched it off then on again and it was fine, what could problem be?, also I think fuel consumption is a bit high, does 350-400 miles to full tank is that normal or high, also how to improve fuel economy. Thanks.
    I think the fuel consumption you stated is normal this is a pretty thirsty engine foe a diesel. I don't know however about your other issues.

    Gazza4

  3. #3
    Regular Member hans_vledder's Avatar
    Join Date
    Jan 2007
    Location
    't Veld - The Netherlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by vectra taxi View Post
    Hi, all, I have just bought a 2.2 dti elegance, beautifull car, but was driving it yesterday on dual carriageway at bout 70-75mph when car with spanner light came on and cars pickup dropped, parked it up switched it off then on again and it was fine, what could problem be?, also I think fuel consumption is a bit high, does 350-400 miles to full tank is that normal or high, also how to improve fuel economy. Thanks.
    Hi,

    There's a number of things that I've done to maximise economy;

    1. Replace MAF sensor after 65K
    2. Install K&N air filter
    3. Clean injectors by using Wynn's Diesel +PLUS+
    4. Have a remap (engine tuning) to maximise efficiency

    By doing so my car's economy went up to 450-500 miles on a full tank, when I don't floor it regularly. With respect to the power drop that you've had; please check the top turbo hose for leaks/holes. See the picture below for the very location this hole usually occurs:



    Good luck,
    Hans
    Last edited by hans_vledder; 25th May 2008 at 13:55.

  4. #4
    Regular Member Wolf's Avatar
    Join Date
    Feb 2008
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi m8. It does look like most of the 2.2 DTIs have the "limp mode" problem and same does mine. It has though improved since I made a software update on the ECU- a huge improvement, but still goes into limp mode every now and again. The problem is my mecanic can't find out what it is and I don't really trust the stellers as they only change parts and charge you a lot of money for it but don't necesarily sort out the problem.Like I said it drives a lot better now after the software update and I hope a remap will sort out the problem fully.

  5. #5
    Regular Member
    Join Date
    Dec 2006
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My 2.2dti Siggy suffered the same twice in nearly 5 years.
    First was claimed to be the air flow meter (MAF) and a software upgrade and the second the dealer took 4 hours to find, luckily still on warranty at the time, and this was a split in one of the small bore vacuum tubes that runs from the vacuum pump to the EGR valve near the turbo. All was fine after that had been sorted.

    As to consumption I always got over 450 miles/tank but how much more depended upon whether it was long distance motorway cruising or around town. Basically the computer usually showed 45 to 50 mpg and I got very upset if it dropped a little which it did when I fitted EBC Greenstuff brake pads. They improved the braking and feel of the pedal but dropped the mpg by 10%! My wife managed 57 mpg on a run but she's lighter in the foot than me.

    I always considered the dti engine, if a little agricultural sounding, to be tougher than the newer belt driven cdti. You don't need to change the cambelt or worry if it was about to break.

    You will also find loads on this forum about turbo and EGR problems on the newer engine so I always considered the dti a better engine and not particularly thirsty.

  6. #6
    Regular Member
    Join Date
    Mar 2008
    Location
    Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I Had a problem like this when I brought my present car 2.0 DTI, the engine management light would come on when I got to between 70 - 80 MPH. It turned out to be a split in one of the vacuum pipes, after it was changed I never had the problem again.

  7. #7
    Regular Member hans_vledder's Avatar
    Join Date
    Jan 2007
    Location
    't Veld - The Netherlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have never experienced this limp mode problem, but I have to say that I got the remap right after having the ECU software updated, which in turn was done within two weeks after buying the car. In any case, please make sure VX updates the software (all of it) first before getting a remap. If not you'll end up with a remap done on outdated software. Not a good start.

    Regards,
    Hans

  8. #8
    Regular Member garvey's Avatar
    Join Date
    Feb 2008
    Location
    Co Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by vectra taxi View Post
    Hi, all, I have just bought a 2.2 dti elegance, beautifull car, but was driving it yesterday on dual carriageway at bout 70-75mph when car with spanner light came on and cars pickup dropped, parked it up switched it off then on again and it was fine, what could problem be?, also I think fuel consumption is a bit high, does 350-400 miles to full tank is that normal or high, also how to improve fuel economy. Thanks.
    Welcome, you will get used to it. I have

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. will these fit my elegance
    By steebdon in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 3rd January 2010, 14:33
  2. my 1st pic of my 2.2 dti elegance
    By paulf in forum Quick Photo Album
    Replies: 6
    Last Post: 3rd February 2009, 20:40
  3. signum 2.2dti elegance egr problems
    By micksig in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 23rd March 2008, 16:23
  4. 2003 2.2dti Elegance (Northern Ireland)
    By LAV6Y in forum Cars for sale
    Replies: 6
    Last Post: 7th September 2007, 16:04
  5. Elegance or not?
    By spacenase in forum Styling
    Replies: 10
    Last Post: 1st July 2006, 05:53

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •