User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: Lumpy idle on 2.2 Direct SRi

  1. #1
    Regular Member Palmo's Avatar
    Join Date
    Feb 2006
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Lumpy idle on 2.2 Direct SRi

    Anyone have any suggestions what may be causing an 04 2.2 Direct to have a 'lumpy' idle. It is not excessive, but noticeable - didn't used to do this. The car is well serviced and runs perfectly otherwise. It's almost as if the car momentarily misses a beat on tickover every now and again.

    Advice greatly appreciated. Are there any common problems that could be causing this?

  2. #2
    Regular Member sparky71a's Avatar
    Join Date
    Apr 2006
    Location
    At the Garage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Possibly coil pack?
    Sounds as if it's missing a bit?

  3. #3
    Regular Member Palmo's Avatar
    Join Date
    Feb 2006
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Could this be the casue though, when it is only doing it on idle? Never misses when driving it, either lightly or under heavy load.

    Not sure if I'd describe it as 'missing' on idle either..... it's a strange one really. I've always thought the tickover was a little on the low side, although after some investigation I found this to be totally normal and in-line with other cars. It was never lumpy though like now - always a constant steady tickover.

  4. #4
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Chain could have stretched a little? On second thoughts get some carb cleaner take off the air filter and spray the carb cleaner through the TB, the 2.2 can suffer a little from deposits around the butterfly, which wouldn't do anything when your foot is down but would show up on idle.

  5. #5
    Regular Member Palmo's Avatar
    Join Date
    Feb 2006
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Already had chain replaced as a precaution previously so can't be that.

    Does the 2.2 Direct Engine have an 'Idle Control Valve'? If so where is it located? Also does this engine have an EGR Valve? Again, if so where is this located?

  6. #6
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Ive just edited my last post mate. Also the EGR is the barrel shaped thing on the end of the lump next to the battery box.

  7. #7
    Regular Member Palmo's Avatar
    Join Date
    Feb 2006
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by rushy View Post
    Ive just edited my last post mate. Also the EGR is the barrel shaped thing on the end of the lump next to the battery box.
    On the right hand side of the engine? I thought that was the high-pressure fuel pump? Are we talking about the same thing?

  8. #8
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    EGR

  9. #9
    Regular Member Palmo's Avatar
    Join Date
    Feb 2006
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by rushy View Post
    EGR
    Thanks very much for the prompt reply - really appreciated! I was thinking about the high-pressure fuel pump which is to the left.

    Do you know if these have an Idle Control Valve?

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    That one im not to sure off. Id clean the TB first, then disconnect (mechanically) the EGR and fit the VX blanking plate, just hang the EGR of of one of the bolts so that it can still work and not send car into limp mode.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.0t edition 100 lumpy idle
    By 6009tristanb in forum Engine & Drivetrain
    Replies: 18
    Last Post: 4th January 2012, 17:02
  2. lumpy idle 2.0 turbo
    By tecg in forum Engine & Drivetrain
    Replies: 8
    Last Post: 14th December 2011, 21:21
  3. 2.2 direct lumpy idle, EML & TC lights
    By kensri in forum Engine & Drivetrain
    Replies: 7
    Last Post: 9th November 2010, 14:10
  4. lumpy idle
    By old cruiser in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 24th November 2008, 20:39
  5. 3.2 v6 Lumpy idle!?!
    By byebyeitsagsi in forum Engine & Drivetrain
    Replies: 20
    Last Post: 13th August 2008, 12:24

Visitors found this page by searching for:

vauxhall vectra c 2.2 sri ideling

vauxhall vectra 2.2 sri not running right on idle

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •