User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Vectra-c newbie with serious problems!!!Advice needed

  1. #1
    Regular Member
    Join Date
    May 2008
    Location
    antrim
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Vectra-c newbie with serious problems!!!Advice needed

    First of all hello to everyone here good job on the site! Now, where do I start.... I own a Vectra C 1.8LS 2002, problem free motoring until last sunday, tried to start the car after a quick stop on a short trip and the engine management light came on and a horrible lumpy sound as the engine tried to start but wouldn't. Got the car taken to a garage and they reckoned after 2 hours of diagnostics and £197 that I needed a new poweer steering pump, now the bill goes up to £955. Picked up the car on the 7th, drove 20 miles tried to start it again and whammo, same problem I just paid best part of a grand having repaired is back. Garage say they fixed the problem and now want to charge more for further diagnostics and different parts if the power steering pump is not the problem. Obviously I am a little bit upset about this and wonder what advice you lot could give me on the possible fault and what to do about the garage?? Thanks in advance for any replies or advice!!

  2. #2
    Regular Member Ian S100's Avatar
    Join Date
    Mar 2007
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Seems to be the normal way with garages these days - garages keep replacing parts which you pay for until, with luck, they manage to fix the problem.

    A friend had the EM light on his Merc come on - The Merc garage replaced the Air Flow Meter & reset the light - which came back on a couple of days later. The garage told him the fault was diagnosed as 1 of 2 things so now they would have to replace the other part but couldn't do anything about the £850 which he had already spent

  3. #3
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    as per your other post..

  4. #4
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    What would the power steering pump need to repalced for if the car would not start. very confused??? New one is £600 and takes about 30 mins to fit and then may have to be tech 2'd in as your old one would have an oil level indicator. The new one will not have. i suggest u check to see if a new one is fitted. Its under the front drivers wing/bumper. I have had a power steering pump go and all it does is make the steering heavy. think u have been done mate!

  5. #5
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by merikiito View Post
    What would the power steering pump need to repalced for if the car would not start. very confused??? New one is £600 and takes about 30 mins to fit and then may have to be tech 2'd in as your old one would have an oil level indicator. The new one will not have. i suggest u check to see if a new one is fitted. Its under the front drivers wing/bumper. I have had a power steering pump go and all it does is make the steering heavy. think u have been done mate!

    yes you right about the steering being very heavy as last year i was driving for 3 months without power steering and i didn't get mine tech 2. some have fluid levels and some dont as for the garage wrongly diagnosed i would tell them to but the old one back on and refund the money as for cutting out it might neeed tech2ed to see if there is any faults on the ecu

  6. #6
    Regular Member
    Join Date
    May 2008
    Location
    antrim
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thinking exactly the same, ripped off, I had a look at the diagnostics sheet and it did say the problem was the EHPS, electric hydraulic power steering they reckoned, got to be honest, not to knowledgeable about cars, as the garage probably are all to aware of!

  7. #7
    Regular Member
    Join Date
    May 2008
    Location
    antrim
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Asked the garage to replace the part with the old one and they said that it was the sensor in the old one due to water ingress and with the old one fitted the diagnosis wouldn't go any further than that component!

  8. #8
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by slyneely View Post
    Asked the garage to replace the part with the old one and they said that it was the sensor in the old one due to water ingress and with the old one fitted the diagnosis wouldn't go any further than that component!
    i cant see how water can get in as it has a tight sealed fluid cap and two pipe that feeds the steering rack withn minerale steering fluid and on the side is 2-3 connector block 1 big block which is for the earth and live feed a cable from pump to rack and the 3rd one is for fluid level if you have it. so as mark said in the other post it WILL not affect any running problems with the engine

  9. #9
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    When my pump went the dash died and the car would not start after I turned it off. Car then started 15 mins later.

  10. #10
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If it's Townparks that ripped you off, tell Rodney to wise up.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I'm going to have to part with my Vectra (advice needed)
    By Karnah in forum Vectra C / Signum Car Chat
    Replies: 21
    Last Post: 20th August 2009, 11:43
  2. Vectra c Est modification advice needed!
    By giles in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 30th June 2009, 17:09
  3. vectra c 2.2 advice needed
    By davidlewis24 in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 18th January 2009, 19:52
  4. Newbie Advice needed please 2.2 Direct with a strange rattle...
    By simp_2.2sri in forum Introduce yourself.
    Replies: 20
    Last Post: 10th August 2008, 17:24
  5. Newbie, Buying a Vectra C advice...
    By C9SRi in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 14th March 2008, 13:15

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •