User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: engine light on

  1. #1
    New Member
    Join Date
    May 2008
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused engine light on

    Hi,
    I am having a problem with Vectra 2002 JS II CD 2.6 V6. The engine light stays on while drving. Got it scanned and it says "catalyst efficiency below threshold on bank1 and bank2".

    I used to have problem with hesitation when accelerating a cold car. Now the problem suddently gone but the engine light turns on. Is it something to do with air leak or exhaust leak?

    appreciate your help.

  2. #2
    Regular Member sparky71a's Avatar
    Join Date
    Apr 2006
    Location
    At the Garage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Knackered Cat,from an earlier slow to diagnose oxygen sensor failiure?
    Have you had the oxygen sensor(lambada sensor) replaced at any time?

  3. #3
    New Member
    Join Date
    May 2008
    Location
    Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have not replaced any oxygen sensors. Just recently did engine flush, changed engine oil pressure sensor and changed engine oil. No problems with driving the car. And engine noise sounds allright.

    Thanks,

  4. #4
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    It could be the sensor mis reading - but still giving a valid reading.

  5. #5
    Regular Member sparky71a's Avatar
    Join Date
    Apr 2006
    Location
    At the Garage
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Clue could be in the engine flush bit........A flush has been known to dislodge muck and appropriate it in places it should be,and given the age of your engine that could be something to think about?

  6. #6
    Regular Member John C S's Avatar
    Join Date
    May 2007
    Location
    Gangsta crossover on the drive? Check
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sparky71a View Post
    Knackered Cat,from an earlier slow to diagnose oxygen sensor failiure?
    Have you had the oxygen sensor(lambada sensor) replaced at any time?

    What's a Lambada Sensor sparky????

    I was on holiday in the caribbean, the music played and my lambada sensor kicked in and I danced all night!!



    (PS, Sorry it's thread from the dead!! But i was searching back for something etc etc)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Engine and Spanner Light Before I Start The Engine
    By corderz in forum Engine & Drivetrain
    Replies: 14
    Last Post: 24th March 2011, 18:48
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Replies: 3
    Last Post: 28th April 2009, 19:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •